Support » Fixing WordPress » Issues with the Read More Tag after editor update

  • Hello forum,

    I have issues with the “read more tag” when I have the blog posts on the homepage and the blog page. The problem occurred with the new editor. If I add a “block” it works on the homepage but not on the blog page. And if I add the old code it works on the blogpage but not on the homepage.

    <!– wp:block {“ref”:2223} /—>
    Works on homepage, but not on blog page

    <p><!–more–></p>
    Works on blog page but not on home page

    If i copy paste the code from an old post from the classic editor and then just change the text to the new post, it works for both the homepage and the blog page, but its really time consuming and not so nice.

    http://www.pebblespilates.com is our website.

    So much thanks for the help!

    Best

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Your home page is a Page, so it always shows all the content of the Page. There is no more for a “read more tag” to show.

    Hi Joy, don’t exactly sure what you mean. If you go to our site, you will see that we have the “read more” button on some of the posts. And now, for the latest post I have the <!– wp:block {“ref”:2223} /—> but then its not folded on the blog page…. If I were to change to <p><!–more–></p> it would be no “read more” button on the home page but on the blog page…

    According to one of the development leads of the new editor, the More block looks like this:

    <!-- wp:more -->
    <!--more-->
    <!-- /wp:more -->

    I don’t know what that block you have is for.

    First one: <!– wp:more –>
    No Read More button on home page, but on Blog Page

    Second one: <!–more–>
    No Read More button on home page, but on Blog Page

    Third one: <!– /wp:more –>
    Read More button on home page, but not on the Blog Page

    So the 2 first gives me no button on home page. and the last one gives me a button on the blog page but not on the home page….

    so weird

    The entire thing (3 lines) is a Read More block (new way to do it). The middle line <!--more-> is a More tag (old way to do it).

    Hi Joy, now is the post with all three lines… But still no button on homepage but a button on the blog page….

    <!– wp:more –>
    <!–more–>
    <!– /wp:more –>

    See the post: https://pebblespilates.com/category/pilates-friends/ and on the homepage (at the bottom) https://pebblespilates.com/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Issues with the Read More Tag after editor update’ is closed to new replies.