Support » Plugin: WooCommerce Stripe Payment Gateway » Issues with Stripe 3.0.3 and 3.0.4

  • Plugin Support Hannah S.

    (@fernashes)


    Automattic Happiness Engineer

    We are aware of the problems that the latest Stripe update (3.0.3 and 3.0.4) caused to some of our customers. A big thanks to those of you who alerted us about the problem: you were crucial in getting this resolved as soon as possible.

    It’s not possible for us to test every possible server configuration, so we also need you to test before updating on your live site. This is especially important when it comes to a business-critical plugin such as Stripe. For more information, please take a look at our update doc:
    https://docs.woocommerce.com/document/how-to-update-your-site/

    Even though we do extensive testing before every update, we are not able to catch all possible configurations. If you were affected, please accept our apologies.

    The technical background is that we had an issue in both versions where certain JavaScript files weren’t included in the plugin. This caused the error Developers: Please make sure that you are including jQuery and there are no JavaScript errors on the page.

    If you have updated to version 3.0.5 of the plugin, done a hard refresh and are still seeing this message, then it is an unrelated issue. Please create a new thread here and we’ll be happy to help.

Viewing 15 replies - 1 through 15 (of 23 total)
  • I can tell you that never had an issue with Stripe at checkout. I updated from 3.0.2 to 3.0.5 (the latest version) and lost 6 orders because the payment did not go through. Unfortunately, as a result of this, I changed to a different gateway.

    It is very sad because if this plugin would have a live chat support or a phone number to call, I along with other users, could feel we can get help when truly necessary.

    Your latest update has literally destroyed it. In addition, when testing it, it showed no issues. When purchasing in production mode. cards would show as pending and these never showed up within the Stripe transactions at the Stripe website.

    I am writing this to help others at this point because I am sure you will hear complaints.

    And the error is the javascript/developer as seen in your post.

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    @liptech This isn’t something that we’ve been able to reproduce in version 3.0.5 in production. I’d really appreciate it if you could create a ticket with us at WooCommerce.com (you’ll need to create a user and then create a ticket > free plugins) so we can take a closer look at your site.

    Hi,
    FYI, that work on my website Rievtech which is Openssl 1.0.1k (TLS1.2 compatible)
    And on my website aceautomation.eu but which is TLS1.1
    I’ve the last version 3.0.5
    Thanks for this PlugIn !

    Same issue with 3.0.5 on all my sites.

    Hey Hannah Swain, thank you. I opened the support with Woocommerce.

    I am glad to see others are having the same issue in the sense that this is not an isolated incident just with my site. I am hoping you can solve it soon.

    In the meantime please, can you send me a link to the version 3.0.2? That was working just fine and wish to get going in the meantime with this older version until you resolve the issue.

    When I click on the 3.0.2 version on the plugin page, it does not offer me a download button or link.
    Can you please, please send it to me and for others?

    Thank you!

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Thanks for creating a ticket – we’ll be glad to help!

    There were a number of fixes in version 3.0.3, so we don’t recommend rolling back. That being said, I do understand that your site needs to work for customers. Here’s the direct link to 3.0.2:
    https://github.com/woocommerce/woocommerce-gateway-stripe/archive/3.0.2.zip

    @lipctech ^

    • This reply was modified 3 years, 4 months ago by Hannah S..

    Thank you! Appreciate it. Demian from Woocommerce wrote me back but he thinks it might be a conflict with other plugins. I do not believe so for 3 reasons:

    Stripe Checkout worked just fine with 3.0.2 and same plugins;
    Other people are complaining of the same issue after updating to 3.0.5;
    This is the same error you were getting with 3.0.3 and 3.0.4 (java, developer error…..).

    I suggest you troubleshoot it on your end as you will get more and more complaints. When it is resolved, please let me know and I will install the new version.

    Very much appreciated it!!!

    To everyone having the issue with 3.0.5 as well, I figured out that on my side it was a conflict with autoptimize which was minifying the javascript. I’m assuming the stripe plugin’s javascript has some errors in it, which would cause problems with minification. If you have a similar plugin (W3 total cache, autoptimize, etc…), deactivating it might solve your problem.

    Just confirmed that their javascript files are missing some semicolons, which is known to break minification plugins.

    Same thing here. Just updated from 3.0.2 to 3.0.5 and starting getting jQuery errors. Rolled back to 3.0.2 and all is good.

    kokomoweb; you could also exclude the stripe js from optimization as a temporary solution?

    Issue happening on this end also.
    Payment not being processed.

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Just confirmed that their javascript files are missing some semicolons, which is known to break minification plugins.

    @kokomoweb – which plugin are you referring to, here? Thanks!

    @futta absolutely, was too lazy tho, haha 🙂

    @fernashes in my case it was Autoptimize but I’m assuming it will also create issues with other minifying plugins.

    I can confirm this is still an issue in 3.0.5

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Issues with Stripe 3.0.3 and 3.0.4’ is closed to new replies.