WordPress.org

Support

Support » Plugins and Hacks » Issues with recent update

Issues with recent update

  • The recent total cache update has jacked up all my sites that use it. I’m using the thesis theme and none of the CSS is being applied whatsoever – the sites now look like a word file with just text.

    Also I’m getting a bunch of red messages in the general settings of W3TC that read like:

    Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file (/home5/achventu/public_html/pharmtechnicianclass/.htaccess) of the site above the WordPress directives . Or if permission allow this can be done automatically, by clicking here:

    There are about 5 of these, where there were none before and I had none of the above mentioned display issues with my site. I’m going from W3TC being usable to totally unusable with this update. Deactivating it until this can be resolved.

    Chris

Viewing 15 replies - 1 through 15 (of 23 total)
  • I have also deactivated it until the problems are resolved.

    Gerhard

    The problem is specific to the CSS minify settings, which is all you have to deactivate. There’s several other threads about it as well.

    http://wordpress.org/support/topic/plugin-w3-total-cache-minify-just-wont-work?replies=3

    http://wordpress.org/support/topic/css-is-broken-with-latest-w3tc?replies=8

    Thanks Chris.

    Did anyone try to:

    1. Reupload style.css file from a theme back up (for those who do not have styles applied at all now)
    2. Reinstal the w3tc plugin (delete current, delete tables, install and set up from start – I do not have a test site I cannot have nowhere try it)

    I use the plugin but I am glad I saw these forums about the recent problems before I updated! The plugin page says that it’s broken (85 votes). I went to the plugin website there isn’t anything described nor a mention, unless I was blind, wondering why because there are so many people with negative issues. Is it possible that the plugin right now is the way as Frederick intends it to be? Is there any forum post here where Frederick talks about a help or a fix or what to do??

    Maybe we are missing something/s? Because in my WP plugins admin page under the plugin update prompt, next to the w3tc update in a pretty looking box, it states what’s copied here below:

    “There is a new version of W3 Total Cache available. View version 0.9.2.1 details or update automatically.
    Take a minute to update, here’s why:
    • Fixed bug with existing installation upgrades: set minify to manual mode by default
    • Fixed bug with unsuccessful transfer queue button
    • Fixed bug with background in lightbox
    • Fixed bug with handling of local http requests being blocked on some hosts
    • Disabled CDN for minify files when auto mode is selected and the CDN method is origin push

    = 0.9.2 =
    • Added support for nginx web server
    • Added support for CloudFlare
    • Added origin pull support for Amazon Cloudfront
    • Added Microsoft Azure Storage support for CDN
    • Added WinCache opcode cache support
    • Added additional minifier engines for HTML, CSS and JS including: HTMLtidy, CSStidy, Closure Compiler, YUI Compressor
    • Added Google Page Speed integration
    • Added support for @import processing
    • Added controls for page cache purging policy
    • Added auto mode for minify (not compatible with CDN)
    • Added support for set cookie domain setting
    • Added reliability improvements for Amazon Web Services
    • Added referrer group management for uniquely caching these cases
    • Added Amazon S3 bucket location selection control
    • Added support CNAMEs confguration support for Amazon Cloudfront
    • Added purge tool
    • Added support of custom wp-config.php location
    • Added cache busting support
    • Improved object caching performance when no plugins are active
    • Improved non-blocking JS embedding implementation
    • Improved reliability of CDN export operations
    • Improved implementation of headers for all cache engines
    • Improved minify help (recommendations) tool
    • Improved handling of .htaccess directive changes
    • Improved support of IIS web server
    • Improved varnish support
    • Fixed bugs with API changes with Rackspace Cloudfiles
    • Fixed bugs with origin push content delivery network methods
    • Fixed bug with HTML encoding
    • Fixed bug with emptying cache for various cache keys
    • Fixed bug with rejected CDN file support
    • Fixed bug with HTTPS mode in WP Admin
    • Fixed bug with relative document root for disk enhanced page cache
    • Fixed bug with trailing slash for disk enhanced page cache
    • Fixed bug with minify template group settings being lost upon upgrade
    • Fixed division by zero error
    • Fixed bug with object cache clones
    • Moved browser cache rules to site root instead of document root”

    for me the site breaks when you’re not logged in….

    it looks like a file without a style.css (althoug it’s there…)

    the non ative page caching can be solved by chmodding your .htaccess to 777 and clcik the notice to update your rewrites, that part works fine…

    but still it breaks my site…

    For anyone who’s experiencing problems with the newest version of W3Cache, this is most likely caused by the ‘minify mode’ set to ‘Auto’. Just disable the minify mode for now or set it to manual.

    Also, make sure that new rules are correctly added to your configuration files. If your file permissions allow it this can be done automatically with a few mouse clicks.

    Turning the minify mode to “manual” doesn’t fix the missing CSS problem anyway.

    Chris1288’s solution worked for me: “The problem is specific to the CSS minify settings, which is all you have to deactivate.”

    Same problem here. I just disabled minify CSS.

    Disable minify mode or set it to manual, write cache rules, empty all caches then try again.. I got it working on 30+ cliënt sites, so you can too.

    Yes is working if you disable CSS minify, but what have changed that new version dont work for css? I can confirm that on 4 different sites i have same problem and turning minify for CSS off will show my site without problem.

    yeap… i’m haing the same issue. Glad i’m not alone.

    Thank you Chris1288… “The problem is specific to the CSS minify settings, which is all you have to deactivate.” This solved it for me!

    It break my sites when I am not logged, I think it is just becuase you have chosen a option “Don’t cacha logged user”. But now, my problem is I can’t get into Admin pages. All pages in admin dictionary can’t be visited , it just show a blank page……So, I have to reInstall my site with all
    files and database, it is terribly suffering me. I hope it can work after reinstalling

    Be careful. Your site may look normal when you are still logged in as administrator. Log out and look at your site to make sure Theme formatting has returned.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Issues with recent update’ is closed to new replies.