Support » Fixing WordPress » issues with plugin install and updating

  • I’ve got a group of about 40 blogs all on the same VPS spread over three different user accounts. I’ve been on this host for about 1.25 years with no issues. The server is running Debian.

    Recently, I’ve been unable to update or intall new plugins via the WP admin panel. When I attempt to do this, it gives me an ftp error. I’m using ‘localhost’ in this setting as I always have (never had this problem before).

    I did some ‘google research’ and found several people saying to make the following change to my wp-config.php file.

    if(is_admin()) {
    	add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    	define( 'FS_CHMOD_DIR', 0751 );

    when I modify wp-config.php in that manner, I get past the ftp error but get the following

    Unable to locate WordPress Content directory (wp-content).

    I’ve also seen it get so far as to say

    Could not copy file. /domains/

    I’ve got a great host who has looked into this as well and we cant find a common cause. I’m seeing this on WP 3.0 as well as 3.0.1 – I’m seeing it across most all my blogs. Sometimes it seems intermittent as occasionally a blog that is malfunctioning will suddenly allow the update, then stop allowing it

Viewing 3 replies - 1 through 3 (of 3 total)
  • update: My host was just helping me on this issue –

    we had installed the ‘core control’ plugin (manually of course) and everything seems ok except that ‘php http extension’ shows not available. This was on a blog that would not currently update.

    I found another blog that would update (tested intall of a plug in) and then installed core-control to see if it had the same ‘php http extension’ message – which it did.

    Then about 60 seconds later I tried to install a plugin to this blog that was just working properly and got the same ‘cant find /wp-content’ error. (note, I changed nothing via core control)

    I’m banging my head here. Pls help

    This problem is certainly intermittant. My host re-built apache because it told him the libssl-dev packages were damaged

    after rebuilding, I tried six blogs in a row and they all worked perfectly. The 7th did not. I went back thru the first 6 that I had checked and 80% of them were not working. This was all in the span of 10 minutes after the apache rebuild.

    Problems are ongoing.

    I just installed WP to a brand new domain. Immediatly after installing WP, I went into the admin panel and updated Akismet successfully.

    Immediatly after that, I started to install All-in-one-seo. I got the same, ‘cant find wp-content ‘ error.

    Does anyone have any help for this, please!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘issues with plugin install and updating’ is closed to new replies.