Support » Fixing WordPress » Issues with my WordPress sites

  • Hi there,

    I have some errors on my WordPress site but I can’t find the solution. I have a second WordPress site but that doesn’t have the same errors. I already tried a default WordPress theme and disabled all plugins. But I still get this errors about loopback and cURL. I run php 7.3.14.

    Error 1

    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.
    
    The REST API request failed due to an error.
    Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)

    Error 2

    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.
    
    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error: cURL error 28: Operation timed out after 10002 milliseconds with 0 bytes received (http_request_failed)

    Error 3

    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.
    
    The loopback request returned an unexpected http status code, 403, it was not possible to determine if this will prevent features from working as expected.

    I also have another issue with multiple sites. I’m not sure if this is a firewall issue. The error is different on each site. I disabled all plugins on the WordPress sites. But the errors are still showing.

    Error 1
    Could not confirm that the wp_version_check() filter is available.

    Error 2
    A plugin has prevented updates by disabling wp_version_check().

    If you need more information. Please let me know. I will provide you with it.

    Almost forget: All my plugins and themes are the last version. WordPress is also up-to-date.

    • This topic was modified 10 months, 3 weeks ago by tbl91.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Yui

    (@fierevere)

    ゆい

    Are you using any security plugins or hardening rules in .htaccess (notably – /wp-json/)?

    https://wordpress.org/plugins/health-check/
    Can you check troubleshooting mode with this plugin? Does the problem persist?

    Thread Starter tbl91

    (@tbl91)

    Thank you for the rely @fierevere!

    This is my .htaccess file. I cleaned it a few weeks ago. I don’t use any security plugins on my website. I have a list of all the plugins I use below the .htaccess code.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    
    #Force SSL
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    
    # Compress
    <IfModule mod_headers.c>
    <filesMatch .*\.(jpg|jpeg|png|gif|ico|js|css)(\.gz)?$>
    Header append Cache-Control "public"
    Header append Expires "A604800"
    </filesMatch>
    Header unset Accept-Ranges
    Header unset ETag
    Header unset Link
    Header unset Pragma
    Header unset Transfer-Encoding
    Header unset X-Pingback
    Header append Vary Accept-Encoding
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}.gz -f
    RewriteRule ^(.*)$ $1.gz [L]
    <FilesMatch .*\.gz$>
    Header set Content-Encoding: gzip
    </FilesMatch>
    <FilesMatch .*\.css.gz$>
    ForceType text/css
    </FilesMatch>
    <FilesMatch .*\.html?.gz$>
    ForceType text/html
    Header unset Expires
    </FilesMatch>
    <FilesMatch .*\.js.gz$>
    # Works in IE8 and older but obsolete - today standart = application/javascript
    ForceType text/javascript
    </FilesMatch>
    <FilesMatch .*\.xml.gz$>
    ForceType text/xml
    </FilesMatch>
    <FilesMatch .*\.txt.gz$>
    ForceType text/plain
    </FilesMatch>
    </IfModule>
    
    #Force mp3 download
    <FilesMatch "\.(?i:mp3)$">
      ForceType application/octet-stream
      Header set Content-Disposition attachment
    </FilesMatch>
    
    <ifModule mod_gzip.c>
      mod_gzip_on Yes
      mod_gzip_dechunk Yes
      mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
      mod_gzip_item_include handler ^cgi-script$
      mod_gzip_item_include mime ^text/.*
      mod_gzip_item_include mime ^application/x-javascript.*
      mod_gzip_item_exclude mime ^image/.*
      mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
    </ifModule>
    
    <ifModule mod_expires.c>
      ExpiresActive On
      ExpiresDefault "access plus 10 seconds"
      ExpiresByType text/html "access plus 300 seconds"
      ExpiresByType image/gif "access plus 259200000 seconds"
      ExpiresByType image/jpeg "access plus 259200000 seconds"
      ExpiresByType image/png "access plus 259200000 seconds"
      ExpiresByType text/css "access plus 60480000 seconds"
      ExpiresByType text/javascript "access plus 21600000 seconds"
      ExpiresByType application/x-javascript "access plus 216000 seconds"
    </ifModule>
    
    <ifModule mod_headers.c>
      <filesMatch "\.(ico|flv|jpg|jpeg|png|gif|swf)$">
        Header set Cache-Control "max-age=259200000, public"
      </filesMatch>
      <filesMatch "\.(css)$">
        Header set Cache-Control "max-age=60480000, public"
      </filesMatch>
      <filesMatch "\.(js)$">
        Header set Cache-Control "max-age=21600000, private"
      </filesMatch>
      <filesMatch "\.(xml|txt)$">
        Header set Cache-Control "max-age=216000, public, must-revalidate"
      </filesMatch>
      <filesMatch "\.(html|htm|php|pdf)$">
        Header set Cache-Control "max-age=60, private, must-revalidate"
      </filesMatch>
    </ifModule>
    Autoptimize	2.7.3	—	
    Cache Enabler	1.3.5	—	
    Cloudflare	3.4.1	—	
    CMS Tree Page View	1.6	—	
    Contact Form 7	5.1.9	—	
    Contact Form 7 Signature Addon	4.2.2	—	
    Health Check & Troubleshooting	1.4.4	—	
    Post SMTP	2.0.12	—	
    PWA for WP	1.7.16.1	—	
    Send PDF for Contact Form 7	0.7.9.1	—	
    Site Kit by Google	1.10.0	—	
    The7 Elements	2.5.0.1	—	
    The7 Ultimate Addons for WPBakery Page Builder	3.19.4	—	
    The7 WPBakery Page Builder	6.2.0	—	
    The Events Calendar	5.1.4	—	
    Yoast SEO	14.4.1 -
    • This reply was modified 10 months, 3 weeks ago by tbl91.
    Moderator Yui

    (@fierevere)

    ゆい

    having your site reverse-proxyed by Cloudflare services can cause loopback problems, your site should be able to reach itself without obstacles.
    You can do so by
    * re-visiting cloudlare settings (not sure what they have, but some sort of whitelisting your site IP can help)

    * avoiding cloudflare for your site when it connects to itself (adding site address to /etc/hosts , you need root access, then restart webserver software)

    * dropping cloudflare and using your real site as real site.

    Maybe someone else, who had experience with Cloudflare, can give more/better advice

    Thread Starter tbl91

    (@tbl91)

    @fierevere Thank you for the reply. I didn’t remove the Cloudflare plugin yet. But I only use Cloudflare for DNS not for performance. It was really slowing down my website. I turned the performance off a few weeks ago. But I removed the plugin. It didn’t resolve the issue I have with the rest api / curl error.

    I just have one question about the /etc/hosts. Why do I need to add my domains to this file? Can this speedup my WordPress website?

    Moderator Yui

    (@fierevere)

    ゆい

    I just have one question about the /etc/hosts. Why do I need to add my domains to this file? Can this speedup my WordPress website?

    In case Cloudflare redefines your site address via DNS, /etc/hosts can make your site connect to itself directly, if you define real IP in /etc/hosts, DNS request will be avoided and WordPress will create loopback connection directly, avoiding Cloudflare. If you use SSL, you still will need to check if you have proper SSL certificate.

    Thread Starter tbl91

    (@tbl91)

    It was a lot of work but I found the issue. A plugin has a bug. I will report it there. Thank you for the quick replies.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Issues with my WordPress sites’ is closed to new replies.