WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Issues with Google Gears (Turbo)

[Resolved] Issues with Google Gears (Turbo)

  • I’m having trouble launching Google Gears (Turbo). During the download of my files it hangs up on:

    “/blog/wp-includes/js/swfupload/swfupload_f9.swf’ returned response code 302”

    I’ve tried both FF3 and IE7 just to make sure its not a browser issue. Is anyone else having this issue or something similar to it?

Viewing 15 replies - 1 through 15 (of 22 total)
  • I should mention that I have tried the following:

    If there are any errors, try disabling Gears, then reload the page and enable it again.

    Still hangs on swfupload_f9.swf.

    Does the site work properly without this plugin enabled?

    If so, disable the plugin and contact the plugin maker.

    i “think” the folder is part of the wordpress core isn’t it? I can’t seem to figure out what plugin I am using that might cause this. I’ll try disabling all plugins and then use turbo.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Are you using any sort of weird redirection stuff or frames or domain hiding or something?

    @rawalex
    nope…disabled all plugins and same error on same file. its part of wp-includes so i thought it was part of the wordpress software instead of a plugin

    @otto42
    my core domain is 301 redirected to domain.com/blog/ that is done with an htaccess file…other then that i haven’t touched anything

    Ahhh, sorry, had to look what google gears is.

    302 status code is file moved ( see http://www.checkupdown.com/status/E302.html for explaination of this code ). It would appear that potentially the current wordpress doesn’t give the type of response that gears is looking for, example returning something other than a swf file as a result. You might want to disable gears and go look at the blog to see what that file is (page source and look for it might do it).

    I personally don’t use image or media uploads (they don’t play out well on rss feeds after) so I am not sure how wordpress treats them.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    What do you get if you try to manually pull up that file in a browser?

    When it tries to pull those files, they are just static files, not going through WordPress in any way. So I have no idea why your site would be returning a 302 for web requests on them.

    Is the /blog/wp-includes/js/swfupload/swfupload_f9.swf actually on the site in that directory? Maybe you forgot to upload everything?

    @rawalex
    Yeah a 302 is just a temporary redirect. Which unfortunately is exactly what is happening. I go to that file location and it drops me on my homepage. URL is the full structure though (http://www.domain.com/blog/wp-includes/js/swfupload/swfupload_f9.swf). All that appears is the same thing as you would see when going to http://www.domain.com/blog/.

    I guess now my question is “Do I need that file/folder” and what will happen if I move/delete it? I don’t know all the ins and outs of wordpress but I think this is the fancy “insert image” editor for the post editor. Can it be removed without breaking things? Is it a better idea to figure out why there is a 302 going on with it? If so, how do I track that down?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    I go to that file location and it drops me on my homepage. URL is the full structure though (http://www.domain.com/blog/wp-includes/js/swfupload/swfupload_f9.swf). All that appears is the same thing as you would see when going to http://www.domain.com/blog/.

    You failed to upload ALL of the WordPress files. If the file is not actually there, than that’s just the sort of error you would see.

    Reupload WordPress. Get all the files this time.

    @otto42
    I guess I answered your question in that last post that I was typing why you posted. If I try and access that file I get dumped on my blog’s homepage but the URL is in tact. I think that’s pretty solid evidence that the 302 is working but I have no idea why there is a 302 going on.

    Do you know if /swfupload/ is critical to wordpress functioning? Again I think it might be part of the “add media” on the visual editor for posting.

    @otto42
    Yep that looks like the issue…I’m looking at the folder in FTP and file is missing. Thanks! I’ll give that a shot and report back.

    @rawalex
    Thanks for all your help as well!

    swf is shockwave / flash files. If you have a post that points to one of those files but you didn’t upload those files, then there would be a problem!

    http://en.wikipedia.org/wiki/SWF

    in wordpress, unless your theme has a 404 page, weird things can happen – you end up with a 302 redirect (probably because of the way you redirect your blog url) and then it will 404… but turbogears probably isn’t seeing the 404 (and without a 404 page it might not even get triggered) and it is waiting for a flash file that will never come…

    I uploaded the missing file and it moved on. Then had the same issue with another swf file in tinymce. No idea why those files were missing but they are there now and the gears installation finished so problem resolved.

    Now…is there anything else I need to do with Ggears? or do things speed up on their own? Does Gears know when to pull data from the local downloaded files on its own?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Gears is automatic, nothing else to do. You should see WordPress’s own images and other things pop up more or less instantly now, instead of loading from the site.

    Obviously, this makes more of a difference on slower connections, but it’s all automatic from that point.

    Awesome, thank you so much again for the help.

    Cliff notes for this thread:
    Gears would hang up on a file during installation and return a 302 error (aka file temporarily moved). WP was giving a 302 because the file was not there and didn’t quite know how to respond (probably due to my lack of a proper 404 file not found page for my template). After copying the missing files from the 2.6 zip file and refreshing the page, the install completed. From here on out Gears is automatic…no further customization needed…also rawalex and Otto42 are very helpful =)

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Issues with Google Gears (Turbo)’ is closed to new replies.