Support » Plugin: Elementor Website Builder » issues with Elementor Plugin

  • Resolved samruddhi

    (@samruddhi)


    Hello! I am facing an issue on my WordPress website. When I click on ‘edit with elementor’ the preview is not being able load with an error that says ‘we are sorry but something is wrong’.
    Also, when you visit the website, it takes a lot of time to load the homepage and some images do not get loaded. This issue is not is not because of an unoptimised website.
    I tried deactivating all plugins and reactivating them one by one. When I activate elementor, the problem is seen again.
    Can anyone help me with this?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Elementor Team

    (@lianakap)

    Hi,

    To troubleshoot the issue please try this guideline:
    Examine Elementor’s system requirements and make sure your website is answering at least the minimum requirements.
    Make sure you are using the most updated versions of Elementor, WordPress & your theme. Sometimes it isn’t apparent that there is an update available. Go to Dashboard > Updates and click the Check Again button to be sure. (Make sure to back up your site).
    Click the Advanced tab and then switch the CSS print method to Internal embedding.
    Clear all cache: your browser’s cache, other plugins’ cache, server cache (if possible).
    If the issue persists, deactivate all plugins apart from Elementor. If this helps, reactivate them one by one to find the culprit.
    If it didn’t help, switch your theme (temporarily) to a default WordPress theme such as Twenty Sixteen and see if it makes any difference.
    From your WordPress dashboard, navigate to Elementor > Settings > Experiments. Change all of the experiments to Inactive. Click Save Changes.

    Also, follow this guide.

    Thread Starter samruddhi

    (@samruddhi)

    So, I have taken these steps, I also tried deactivating Elementor. The issue is only seen if I activate elementor

    Plugin Support Elementor Team

    (@lianakap)

    Hi,

    Please send me a screenshot of the JS console that shows right after the editor throws an error.
    https://elementor.com/help/how-to-open-a-browsers-console/#:~:text=Chrome%3A Press CTRL%2BSHIFT%2B,right to the Console tab.

    sdonikian

    (@sdonikian)

    Hello,

    I am also having some critical issues with Elementor. I deactivated all plugins and isolated Elementor as the culprit (or so it seems).

    I’m working on a site and am encountering Server error 500 and Critical errors when attempting to update my pages.

    Yes, all my plugins, WP and theme are up to date. Memory limit (512M), PHP version (7.4) is also as per plugin requirements (Elementor and WPML being the backbone).
    See a screenshot here: https://webfairy.ca/transfer/config.png

    When I try to edit Home page English version, I get the “Critical error on your website” error message.

    With 2 other pages on the site, I can:
    1) edit the English translation (no critical error page)
    2) view the page, but the incorrect language is displayed
    3) edit in Elementor, but can’t save my changes. I get Servor Error 500 when updating the page.

    I disabled ALL plugins except for WPML and Elementor and still had these problems.

    I then disabled Elementor and the only plugins that were active were WPML. I was then able to edit home page AND all the English content that was not displaying, along with all the unsaved changes were in fact there. Reactivating Elementor caused those same above issues.

    See console error messages here: https://webfairy.ca/transfer/console.jpg

    I hope you can point me in the right direction.
    Thx!

    sdonikian

    (@sdonikian)

    I tried the “Save as Template” method found on this page: https://elementor.com/help/500-error/ and it worked. Until I tried editing the page again with Elementor and got the same Server error 500 all over again.

    My hosting provider directed to me the plugin developer.

    Any insight would be very much appreciated.

    Thread Starter samruddhi

    (@samruddhi)

    Plugin Support Elementor Team

    (@lianakap)

    Hi,

    It seems like there is a server error.

    502 error is shown and since your hosting is operating as a Proxy and getting data are coming from another server. The other server with data did not respond to the proxy one.

    You may report the error 502 to your hosting provider support.

    https://www.howtogeek.com/356389/what-is-a-502-bad-gateway-error-and-how-can-i-fix-it/

    Thread Starter samruddhi

    (@samruddhi)

    Hi, thank you for your help but apparently, it was an issue with the CDN. I had to disable the CDN feature from Godaddy and it solved the issue.

    Plugin Support Elementor Team

    (@lianakap)

    Hi,
    Thank you for the update.

    I’m glad to hear that the issue has been resolved now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘issues with Elementor Plugin’ is closed to new replies.