Support » Plugin: Translate Multilingual sites - TranslatePress » Issues with background video, please help

  • Resolved TNG1

    (@tng1)


    Hi All,

    Just found your plugin and giving it a go for the first time. Love how simple it is to use but I am having a problem with a looping background video on my landing page. If you go to the link and view the site in native English you will see it. When you go to Spanish it disappears.

    I understand your plugin has the ability to swap out media but I can not find anywhere how this background is being addressed let alone deleted.

    If you inspect the code it is the same both before and after the translation:

    <div class="elementor-background-video-container">
    													<video class="elementor-background-video-hosted elementor-html5-video inited fcunited_resize trx_addons_resize" autoplay="" muted="" playsinline="" loop="" src="wp-content/uploads/2022/05/low.mp4" style="width: 1500.11px; height: 843.812px;"></video>
    											</div>

    Can someone please help me…

    Thank you in advance for any replies.

    Cheers,

    Pete

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Alex

    (@alexcozmoslabs)

    Hi,

    You might have a bug or conflict with your current theme/plugins.

    Can you please visit TranslatePress -> Settings -> Advanced.
    Then, enable these features 1 by 1 in this order and try to see if it makes a difference. Disable them back if it makes no difference. Also please disable or clear the cache if you have any.

    1. Fix spaces between HTML attributes
    2. Fix broken HTML
    3. Fix missing dynamic content
    4. Disable dynamic translation

    Thread Starter TNG1

    (@tng1)

    Thanks for the quick reply Alex.

    So far, no joy…

    Cache: I do not use any caching plugins and I have cleared all my browser cache between each attempt to troubleshoot this. If I am missing something obvious here, my apologies and can you please point me to what I’m missing.

    1. I can not find the option to “Fix spaces between HTML attributes”. That said I did update your plugin this morning, could that option have been discontinued in the update? I’m currently running 2.3.1

    2. Fix broken HTML did not affect the issue
    3: Fix missing dynamic content did not affect the issue
    4: Disable dynamic translation did not affect the issue

    I disabled all of my plugins except for TranslatePress and Elementor & Elementor Plus and that did not solve the issue.

    No difference when viewed through Chrome, Firefox, Safari, or from desktop or mobile.

    What’s my next best step?

    Cheers

    Thread Starter TNG1

    (@tng1)

    Still haven’t been able to solve this after following the above suggestions, would greatly appreciate your help here.

    Cheers

    Plugin Support Alex

    (@alexcozmoslabs)

    Hi,

    Let me know exactly what block did you use for the background video? I will try to replicate on my local to see if it’s a bug.

    • This reply was modified 2 months, 1 week ago by Alex.
    Thread Starter TNG1

    (@tng1)

    Alex,

    Thanks for the reply.

    In preparing a reply to you I figured out the issue!

    I am using Elememtor Pro, so no block, but an Elementor section. The video is a self-hosted file. In the style tab of the editor for this section, I had the link to the video file, as you can see HERE

    The link I used was wp-content/uploads/2022/05/low.mp4 which served up well and worked in all ways except for when translated through your plugin.

    If you are eagle-eyed, you might catch…I haven’t for a couple of weeks now…that the link started with “wp-co….” by changing it to “/wp-co…” (adding the / ) and fixed my issue. Sloppy on my part…but I’m probably not going to be the only one to run into this.

    I appreciate the offer of support and love your plugin.

    Cheers…

    Plugin Support Alex

    (@alexcozmoslabs)

    Hi,

    Thank you for the feedback.
    Also, glad to know you fixed it.

    Kind Regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.