Support » Fixing WordPress » Issues with Autosaving in 5.0 Editor

  • David

    (@unsungher0)


    When I am writing and editing a new post on WordPress 5.0, I get some weird results if I am typing while the editor decides to start autosaving. When autosaving, the cursor is automatically moved to the start of the block and then anything that I type will also send the cursor to the start of the block so that what I type shows up backwards in a place that I did not want it to be in the first place. This is extremely annoying behavior that is hindering me enough in my writing that I signed up to wordpress.org just to send you this report. Any idea why this is happening? Can I disable autosave so that it does not get me out of my writing flow every 60 seconds or so? Thanks

Viewing 5 replies - 16 through 20 (of 20 total)
  • Thanks @dleigh first I was made aware of that issue. Strange no one posted this over in our Support Forum or GitHub or even mentioned any of our developers in these tickets. I’m escalating to our developers.

    FYI, This is fixed with CMB2 2.6.0, available now. Even if you’re using a theme or plugin which bundles CMB2, if you install the CMB2 plugin, it should fix the issue as CMB2 always loads the most recent version of itself.

    petere

    (@petere)

    I have the same issue. I disabled all plugins that enhanced the previous editor, but the issue remains and makes it impossible to edit a post. I can type until the first autosave, then it jumps. When I correct, scroll down and start typing again, the editor jumps back to the top after a few seconds (so not after 60 seconds autosave, but almost immediately with each edit), where the rest of the typing ends up.
    Totally unworkable!

    I’m using WP 5.0.3 on Chrome 71.0.3578.98

    jas8522

    (@jas8522)

    @petere I’d bet either something was cached when you disabled the plugins or (more likely) your theme uses some hooks that integrate with the WordPress editor and they haven’t updated this code to work properly with Gutenberg yet.

    petere

    (@petere)

    Thanks @jas8522, must have been the cache, it’s solved now.

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Issues with Autosaving in 5.0 Editor’ is closed to new replies.