• Resolved jetxpert

    (@jetxpert)


    Very disappointed. Version 3.1.6 of your plugin has made things worse.

    Issues:

    [1] Emailed Reports:

    (a) The colors used for the bounce rate are wrong. As stated before, a downward (negative) trend should be Green. Your reports are showing Red.

    Bounce Rate Color Incorrect: https://prnt.sc/xo6sat

    Here’s a great link to understand better the concept of “Bounce Rate”:

    https://backlinko.com/hub/seo/bounce-rate

    From the above article: (Reason why a High Bounce Rate or increasing trend is bad or Red)

    A high Bounce Rate lets you know that your site (or specific pages on your site) has issues with content, user experience, page layout or copywriting.

    (b) The icons for some browsers are broken. Specifically, the icons for the Browser “Mozilla Compatible Agent” and Mobile Device “S11 Lite.”

    Email Report Broken Icons: https://prnt.sc/xo6rb2

    [2] Dashboard:

    (a) The datepicker is not working. When we select the current date, and then click on “View Stats,” the date always reverts to Dec 26, 2020 – Jan 26, 2021.

    (b) After selecting a random date range with the datepicker, the graphs do not correspond (display) for the dates selected. They always revert to Dec 26, 2020 – Jan 26, 2021 or don’t display at all.

    (c) Under “System Stats” and “Social Media” your icons are distorted and/or don’t properly line up in the table displayed.

    System Stats Bad Icons: https://prnt.sc/xo6ofl

    Social Media Bad Icons: https://prnt.sc/xo6pm6

    Please review and fix ASAP.

    Thank you.

    • This topic was modified 4 months, 3 weeks ago by jetxpert.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Adnan

    (@hiddenpearls)

    Hi @jetxpert

    I see.

    Our dev team is gonna solve these issues ASAP, Thank you for reporting the issues.

    Thread Starter jetxpert

    (@jetxpert)

    Hi @hiddenpearls,

    Thank you. Just now … added screenshots (see above).

    Special Note: Your other plugin, “Google Analytics Dashboard Widget“, is also affected by this. Meaning, the datepicker of one plugin seems to be affecting the datepicker of the other plugin.

    Hope this helps.

    Cheers!

    Plugin Support Asad Shahbaz

    (@artisticasad)

    Hi @jetxpert

    We have tested the bounce rate in the email reports and its working as expected
    https://monosnap.com/file/7oshoahgQuX9lg1BaRsqBRdsnwkcZX
    https://monosnap.com/file/Q3Z6zIVM6QWgbeVPvLEEhB9aZJQJcX

    The dates are also working in normal manner. Try clearing plugin’s cache, Navigate to Analytify’s settings page Help tab and press the Delete Cache button as in the screenshot here: https://nimb.ws/VJHk7g

    If you are using Analytify Pro addons, please make sure you have all the plugins updated.

    For the icons issue, can you please provide us the email on which you have the broken icons.
    I would suggest to contact us on our support channel https://analytify.io/support/ as we need some additional information so we can work on these issues.

    Thank you for your detailed feedback šŸ™‚

    Looking forward,

    Thread Starter jetxpert

    (@jetxpert)

    Hi @artisticasad,

    Thank you for your guidance. We performed your tests. Many items fixed.

    We also performed a plugin conflict test and determined that a snippet (see below) we added recently via the plugin, Code Snippets, to remove version numbers from scripts and styles in our website was affecting your plugin.

    We deactivated the snippet and most items are now working, excepts as follows:

    (1) Bounce Rate Colors:

    Colors are displaying properly in the Analytify Dashboard. Unfortunately, they are not displaying properly when we send a test email.

    Dashboard Results: Bounce Rate Color Working Properly.
    Test Email Results: Bounce Rate Color Not Working Properly.

    (2) Icons or Logos for Browsers and Mobile Devices:

    The alignment issues are now working except some icons do not display correctly or not at all. They need to be defined.

    Dashboard Results: Icons or logos missing or not defined.
    Test Email Results: Icons or logos missing or not defined.

    Almost there. Kindly review and fix.

    Thank you!

    —————————————

    * Snippet: (conflicts with your plugin, but you can ignore)

    /* remove wp version number from scripts and styles */
    function remove_css_js_version( $src ) {
        if( strpos( $src, '?ver=' ) )
            $src = remove_query_arg( 'ver', $src );
        return $src;
    }
    add_filter( 'style_loader_src', 'remove_css_js_version', 9999 );
    add_filter( 'script_loader_src', 'remove_css_js_version', 9999 );
    Plugin Support Asad Shahbaz

    (@artisticasad)

    Hey,

    I am not sure why are you getting the wrong arrow in the email. The screenshots I have shared in my last message are of the email report send with the latest version of Analytify showing correct arrows and colors.

    However, we will still look into the issue on different environment if we are able to replicate the same issue. But so far we are not able get this issue anywhere else.

    As for the icons, we are aware all icons are not defined as there are too many different devices around and user can be any of them. That is the reason we are showing a default grey icon for not available devices.

    The alignment issue is in under work and for broken icons in the email, it will be awesome if you can provide a copy of the email report you have received with distorted icons, that will help us in great resolving your issue.

    You can provide email report on our support form: https://analytify.io/support

    Cheers āœŒ

    Plugin Author Adnan

    (@hiddenpearls)

    hey @jetxpert

    I dig deeper in your feedback and we noticed you are using old email addon code. Please update to the latest version of the Email addon which will replace the fix of bounce rate plus new designs šŸ™‚

    and with default icons, we have a grey icon/image to use for the devices we don’t have the images. Do you have a better design idea for default device icons?

    Thread Starter jetxpert

    (@jetxpert)

    @hiddenpearls, @artisticasad

    Thanks for your help. We’ll give it a try and report back.

    Concerning the default icons, yes, I can see the challenge of keeping up with all the browser and device logos or icons in the market. Perhaps you can develop an algorithm that will generate a “generic” or custom icon for all browsers or devices that are not in your database. Great opportunity for some creativity šŸ™‚

    To assist further, we performed an email test by sending a report to gmail, yahoo. outlook, and roundcube. Results:

    Gmail: https://prnt.sc/xro92v
    Yahoo: https://prnt.sc/xroat3
    Outlook: https://prnt.sc/xro6k2
    Roundcube: https://prnt.sc/xrocwv

    The idea is to inject a generic icon or logo when one is not found in your database.

    Perhaps your updated plugin already does that. If so, great!

    Again, thank you!

    Thread Starter jetxpert

    (@jetxpert)

    @hiddenpearls,

    Thanks for your help. Problem solved.

    We have emailed our recommended icons to support [at] wp-analytify [dot] com.

    Feel free to use and/or modify them as you please.

    Issue closed.

    Cheers!

    Plugin Author Adnan

    (@hiddenpearls)

    @jetxpert Thank you! I appreciate it a lot.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.