Support » Plugin: TheThe Image Slider » Issues since moving to 3.5

  • Has anyone else had a problem with images not loading since upgrading to 3.5? At first I thought it was an issue with the (borrowed PC I was looking at) but then when I tried on my mac it was the same on there.

    Basically, the loading bar just keeps on loading but nothing ever comes up. No new plugins have been added, no major changes to the theme or anything. It was fine and now it’s not.


Viewing 12 replies - 1 through 12 (of 12 total)
  • I had the same problem, and this is what I did. Comment out or delete this block of code, found in thethe-image-slider.php:

    wp_deregister_script( 'jquery' );
       	wp_register_script( 'jquery', '', false, '1.6.4');
        wp_enqueue_script( 'jquery' );

    I was having the same issues since moving to 3.5 and deleted the block of code suggested by jtfordham and it worked. I noticed that this plugin is compatible only up to WP 3.3.2. My concern is when the developers create an updated version to be compatible with WP 3.5 will stripping these codes cause a problem or will they be rectified with the updated plugin? Thanks in advance.

    this worked for me too! (y) thanks very much jfordham 🙂

    I just tried this fix and it isnt working for me yet. also tried to remove the check mark beside resize images.

    boom just started to work

    Ths only works when you have Resize Slides turned off


    This has been an EXCELLENT plugin over the years (TheThe Fly image slider) .

    Hoping an upgrade will come out soon on top of 1.8 version.

    I have looked over the forums and here is a small list of what i have tried but not luck.

    I will say it seems to work fine if you make a NEW slider..but existing sliders just spin in a gray box.
    I have a NEW Mac so that should not be the issue. (Shows fine TheThe Fly image slider in older WordPress but not in the new..I even used the OLD Plugin installed into 3.5 but no luck)

    Really Weird = I notice when i go to the HOME Page site is doing the same thing (no view) and they are the ones who created this plugin?
    I viewed it across 3 browsers, Fierfox, Chrome and Safari and cleared cookies..are they eve aware of this or am i the only one seeing this?
    Does the support team offer know about this? is my BIG PROBLEM

    On previous slides created back in older TheThe Fly 1.6 when I when I click “edit slide” it simply says “Adda new slide”. No editing allowed on existing slides for some reason?
    I NEED

    Here is what I tried so far:

    (NOTE..the following DID fix this issue for some folks but just did not work for me)

    I DID do a Backup before going to 3.5 Thank goodness so I will just split the job in two blogs side by side for now.

    01 = Tried this too…No Luck:
    I Turned of Simple Lightbox plugin and kept Fancy Box plugin. Why? because even the New 1.8 slider would not preview if i did not!

    02 = Tried this too…No Luck:
    Comment out or delete this block of code, found in thethe-image-slider.php:

    wp_deregister_script( ‘jquery’ );
    wp_register_script( ‘jquery’, ‘’, false, ‘1.6.4’);
    wp_enqueue_script( ‘jquery’ );

    03 = Tried this too…No Luck:
    Turn off “resize image”.

    04 = Tried this too…No Luck:

    i just had the same problem (and a few others like the DB Connection is VERY VERY slow and it seems that it overloads MySQL by Backend) but i found a fix to let them show your images.

    CHMOD 777 to /wp-content/plugins/thethe-image-slider/cache/

    Create index.html in the Directory and then set chmod 777 on this file too.

    05 = Tried this too…No Luck:
    Please check your plugin cache directory “thethe-image-slider/cache” has writing permissions: 0757 or 0777. Give us a link to check if the problem still exists.

    06 = Tried this too…No Luck:
    I worked out my problem – it may just help some-one else. I had the slider working nicely in development using local host. When I uploaded everything I duplicated exactly where the folder where the images were stored was located. Problem was localhost was hard coded into the image slider, rather then the link to the images being relative. Once I hard coded the link to the images to be that of the live website it has worked well.

    07 = Tried this too…No Luck:
    This is not a problem with the plugin. It is a problem with timthumb.php and can be easily corrected.

    1. Go to the plugin editor
    2. Select “The The Image Slider”
    3. In the plugin files, select “thethe-image-slider/timthumb.php”
    4. On line 212 (depending on your setup,) you will see:
    $this->src = preg_replace(‘/https?:\/\/(?:www\.)?’ . $this->myHost . ‘/i’, ”, $this->src);

    Change this line by commenting it out. It should look like this:
    //$this->src = preg_replace(‘/https?:\/\/(?:www\.)?’ . $this->myHost . ‘/i’, ”, $this->src);

    Based on what I’ve read above and for the people that were still having problems, I’m bettin this will work.

    Good luck.

    08 = Tried luck:
    Tried everything else, nothing worked. The timthumb.php fix actually broke the src link to the slide images for me.

    I removed lines 35-37 in ‘thethe-image-slider.php’. They removed the current jquery file and reverted back to version 1.6.4. Not sure why the developer did this, as it could potentially break stuff on the site that may depend on the latest version of jQuery (I’m running 1.7). Anyway, just deleted those lines and then their jquery for the plugin loaded (that was how I found the issue – the javascript wasn’t loading which is why the slides weren’t showing – they’re classes were never being changed to ‘show’).

    Hope this helps some people out.

    Remove these lines from ‘thethe-image-slider.php’:

    wp_deregister_script( ‘jquery’ );
    wp_register_script( ‘jquery’, ‘’, false, ‘1.6.4’);
    wp_enqueue_script( ‘jquery’ );

    09= THis is the ONLY one I did not do but i do not understand what this person is saying:

    Hi guys, I just installed this plugin,
    Linux deBroglie 3.6.10-2.fc16.i686.PAE #1 SMP Tue Dec 11 19:10:54 UTC 2012 i686 i686 i386 GNU/Linux
    Welcome to WordPress 3.5

    chown -R 777 *

    in the plugin directory!

    I get a loading bar and nothing else. Has this been addressed?


    Re: Images Not Loading
    on: December 30, 2012, 05:36
    rm -rf thethe*

    If I cannot get this to work..doe anyone know where i can get another nice slider plug similar TheThe Fly image slider?
    Please..if ANYONE has the answer let me know or I am going to have a solid week of rebuilding all these beautiful sliders by hand and it is all due tonight!



    @jtfordham YOU ARE AWESOME!

    Thank you. I have so many sites that use this plugin and finally this is a solution, albeit a bandaid fix. I hope the authors update the plugin as I love it!

    Commented out the code using bulk comment tags, so this:

    wp_deregister_script( 'jquery' );
       	wp_register_script( 'jquery', '', false, '1.6.4');
        wp_enqueue_script( 'jquery' );

    Becomes this:

    /*wp_deregister_script( 'jquery' );
       	wp_register_script( 'jquery', '', false, '1.6.4');
        wp_enqueue_script( 'jquery' );

    Works like a charm. Thank you!


    Thanks, but unfortunately, this solution didn’t work for me. I have updated WP up to 3.5.1 version and have the latest version ( ) of the the fly plugin, too. Can this be the reason?

    PS I’ve just visited the plugin’s webpage- it seems like it’s not working as demo there, too –

    I tried the same thing you mentioned, but it doesn’t work with my case, and my WP is 3.5.1, the-the-image-slider is as well.

    I’m on 3.5.1 and just installed The Slider and everything seems to be working fine.
    This has to be one of the most versatile sliders i’ve come across so hope it sticks around for time to come.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Issues since moving to 3.5’ is closed to new replies.