Support » Plugin: Participants Database » Issues and workarounds with CSV upload

  • First of all, thanks for building such a powerful and flexible plugin. I really appreciate it and will donate accordingly.

    After a lot of trial and error, I ran into several issues with CSV upload. Here they are, some of them have workarounds.

    1) Default value not assumed. When you upload records you are creating records. I would expect a new record to be created with the default value set as specificed in the manage fields table, even if you are not uploading that field in your CSV. This does not happen. If you want to set the field, you must upload the field, and put a value in the upload.

    2) Upload image field not uploading. There are some exceptions to the rule in (1). For example if the field-type is Upload image. If you upload text to that field e.g. imagename.png it sometimes takes and other times doesn’t – there must be some dependency on other fields. I got it to work a few times, but now it wont – I have not been able to isolate it. I fixed this by putting this filename in the default, and it puts the Default value on all records, and ignores the input. This is only useful for priming the database with a default image different from the No Image.

    3)Web link fields not uploading. It will not upload URLs to link-type fields. I’ve tried everything: With http://, without. In quotes, not in quotes. In a different position in the field list. The only solution I came up with was to change the field type to text-line, and then enabling the setting “if a “text-line” field looks like a link (begins with “http” or is an email address) make it clickable”. But this introduces more vulnerability to spammy inputs, people putting URLs in every field.

    4) Spanish characters get dropped (á,é,í,ó,ú,ü,ñ,Ñ): This applies in any field, and putting it in quotes makes no difference, the full contents of the input field still gets dropped. Did not find an acceptable workaround.

    Feature request:
    More flexible field labels. In some use cases it makes sense to show the field labels, and in others it does not… you have 3 default displays: List, Single, Record… for example if I have a logo, in my records in the list view I don’t need a label to say logo, nor in the single record view, which is intended for the end-user… they can see the logo, and don’t need to be told its a logo… but on the new record creation, or record editing mode, if there isn’t already a logo, the users is prompted with “choose file”, it would make sense to call this out as being Logo field.

    But right now, one Display setting + the presence of Label text or no text in Manage Fields applies to all three instances.

    Again, thanks for your great plugin and for your diligent support.

Viewing 1 replies (of 1 total)
  • Plugin Author xnau webdesign


    Ahh, great feedback. I’ll have to check into these things and see if they need to be fixed or changed.

    1) I think this is a good idea

    2) I have not been able to duplicate this bug, so if you learn anything more about this, I’d appreciate hearing about it

    3) Yeah, that needs work. The way it works currently is the field is expected to be in “markup” format: [xnau webdesign]( This is undocumented and it should be able to accept bare URLs. I did it that way so it could be exported as text.

    4) That is certainly a problem with the encoding. It must be UTF-8 all around. This works, it’s been tested, but let me know if your experience is otherwise.

    Field labels: you make a good point, and this can be done in a custom template. If you want a quick explanation of how to do this, let me know.

Viewing 1 replies (of 1 total)
  • The topic ‘Issues and workarounds with CSV upload’ is closed to new replies.