Support » Plugin: Popup Maker - Popup Forms, Optins & More » issues after updating to 1.4.7

  • Resolved Jim

    (@incognitoj)


    I’ve just updated Popup Maker to Version 1.4.7, and I’m using the most recent version of WordPress (4.5), but after updating Popup Maker, the plugin said it needs to update the database. I followed the prompt, but it says it failed. Now in the wordpress admin I’m getting a notification that says:
    “Popup Maker needs to complete a database upgrade that was previously started, click here to resume the upgrade.”

    However, when I try to complete it, it still gives me that same messages saying “Upgrade failed, please try again.”

    The popup maker seems to be working fine, but I’m not sure what’s up with this error message and if this is something that I can dismiss.

    Thanks!

    https://wordpress.org/plugins/popup-maker/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author danieliser

    (@danieliser)

    @jim – Sorry to hear that, sounds like something occurred after everything finished but before the the resume option could be cleared. I will whip up a peice of code you can add to your theme temporarily to clear it out. Before that though I would recommend checking that your popups have valid conditions, triggers & cookies. If any came up missing that you didn’t have set that way specifically then it may not have completed.

    Also if possible check your php error logs and see if an error occurred so that we can resolve the underlying problem as well.

    Hope that helps.

    I am not able to update Advanced Theme Builder:

    Popup Maker – Advanced Theme Builder
    Deactivate | Edit

    Version 1.0.2 | By Daniel Iser | View details
    Update Failed: Plugin update failed.
    Select Popup Maker – Age Verification Modals
    Popup Maker – Age Verification Modals
    Deactivate | Edit

    Version 1.1.0 | By Daniel Iser | Visit plugin site
    Select Popup Maker – Unlimited Themes
    Popup Maker – Unlimited Themes
    Deactivate | Edit

    Version 1.0.1 | By Daniel Iser | Visit plugin site

    Plugin Author danieliser

    (@danieliser)

    @carrrrrlos – Please contact support directly for extensions. https://wppopupmaker.com/support.

    Jim

    (@incognitoj)

    The only error in the PHP log on the day I did the upgrade is this:

    Object of class WP_Error could not be converted to string in /home/nicolegi/public_html/wp-content/themes/inovado/framework/inc/breadcrumbs.php on line 73

    I don’t know exactly what that is, but I think it’s unrelated.

    I’m not sure how to tell for certain if the cookies/conditions/triggers are all valid, but they appear to be. The only way I could think of verifying that is to see if the popup works as expected. I have my pop-ups set to show up after about 8 seconds (which works) and to wait 2 week before they show up again. I can’t wait 2 weeks to find out if it appears again, but upon reload it doesn’t show the popup again, so it appears the condition and the cookie are both fine.

    I thought about creating a new pop-up with a short delay, but I’m hesitant to do so on my live site. I would create it on my dev site, but the upgrade worked just fine there.

    My guess is that you’re correct… something occurred after the update finished, but before it got rid of the message. But my assumption of that is only because I don’t see any issues.

    Thanks for your help with this!
    -Jim

    Plugin Author danieliser

    (@danieliser)

    @jim – Not a problem, let me dig into the code and see which option we need to delete to make it go away.

    Jim

    (@incognitoj)

    Just curious if there is any update on how to remove this message.
    Thanks!

    Plugin Author danieliser

    (@danieliser)

    @jim – Try adding delete_option(‘pum_doing_upgrade’); to your themes functions.php file then refresh a few times and remove it. That should clear it out, sorry for the delay.

    Jim

    (@incognitoj)

    Before I do this, I just wanted to ask about an issue I just noticed today.

    I’m not sure if it’s related or not, but I noticed the pop-up is not behaving as I expected on mobile. The close box button doesn’t work. When I press it I can see it registers me pressing it because the color of the button changes, but it doesn’t actually close the box.

    I’ve never noticed this issue before. Could this be relate to this update? Perhaps this update actually did fail.

    I’m not sure if it matters, but the site is startupfashion.com.

    Thanks again!

    Jim

    (@incognitoj)

    actually, the close button seems to be working fine now. Not sure why it wasn’t before. I’ll give this code a shot. Thanks!

    Plugin Author danieliser

    (@danieliser)

    @jim – Yea, doesn’t sound related. If its working on desktop and you have new conditions & triggers interfaces in editor then upgrade completed.

    Glad you got it working, Please take a moment to rate and review the plugin and or support.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘issues after updating to 1.4.7’ is closed to new replies.