Support » Fixing WordPress » Issues after restoring WordPress install using Digital Ocean droplet

  • ilew

    (@ilew)


    After encountering an error when trying to update my theme, I had to restore a digital ocean snapshot to get my site back online. The snapshot was only a few hours old. The site started working again, but I’m now encountering several errors so something seems to be wrong.

    The errors include:
    – An inability to set a featured image in a post
    – If I open an existing post and then save, its featured image and metadata get stripped
    – If I open the media library, I can see thumbnails of the images, but if I try and search for a file/image there are no results

    I’ve disabled some plugins that I thought might be culprits, but still can’t identify the issue. Does anyone have any ideas as to what might have been messed up as a result of the restored snapshot?

    To be clear, the current version of the theme was working fine yesterday, prior to the restoring of the snapshot, so I don’t think the theme is the issue.

    Clearly, this is quite frustrating as I now can’t edit any posts for fear of stripping them of their featured images and other metadata (e.g. SEO title/description etc).

    Any help would be much appreciated!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • jjberry

    (@eltobiano)

    Hi @ilew
    I hear you it is a frustrating issue.
    It’s a long shot since I don’t have too much information, but I’d check file permissions in the uploads folder maybe.

    Let me know if you find any other useful information for troubleshooting.
    Cheers

    Thread Starter ilew

    (@ilew)

    Just to update, after many hours I decided to run the WP repair function (wp-admin/maint/repair.php) and it identified the following:

    The ftfy0q_postmeta table is not okay. It is reporting the following error: Table is marked as crashed and last repair failed.

    WordPress then repaired it and gave this output: ftfy0q_postmeta: Number of rows changed from 0 to 531910

    Everything now seems ok other than RankMath acting a bit strange by not populating the post title and description, but maybe it’s unrelated.

    Thanks for your reply jjberry, it’s much appreciated.

    jjberry

    (@eltobiano)

    I’m glad to hear you sorted it out.
    Take care

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Issues after restoring WordPress install using Digital Ocean droplet’ is closed to new replies.