• alessandrovizzino

    (@alessandrovizzino)


    These are the remaining defects/issues, for what we have seen, after 4.0.2 upgrade:
    – In the Audience>Contacts section, some characters are not recognized (for example, if I write for contact name L’ALBERO, it recognizes it as L’/ALBERO, with the /.
    – Select active/inactive and creation new Post notification don’t work.
    – Post notification doesn’t send notification email to subscribed contacts.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor Nirav Mehta

    (@niravmehta)

    Thanks for the feedback!

    Special characters: We’ll fix that soon. Will also check if there are any other areas of the application where this issue exists.

    “Select active/inactive and creation new Post notification don’t work” – can you please clarify that a bit further?

    Post notifications are NOT sent immediately on purpose. A lot of people were complaining about system slow downs due to immediate email sending – we moved this to background jobs – that execute hourly. So email sending should be more reliable now – just that we didn’t communicate this properly. We will continue enhancing this further.

    The ‘/ issue comes up in other areas too, for example in a form, if you have “there’s” it shows “there’/s”.
    Also, all my emails, after eventually having been sent, bounced back due to identification as “505 potential spam”.

    • This reply was modified 1 year, 1 month ago by antya63.

    I’m having the same issue. After 10 months of successfully having Post Notifications sent promptly after a new post goes live every Monday, today’s post did not get emailed to anyone despite a new post going live.

    I’ve confirmed via the Reports that no email was sent out today, so it’s not a SPAM issue on the receiving end. It’s not being generated nor sent.

    The post went live maybe 4 hours ago, which seems a bit long for emails to not be sent even as background jobs.

    And as antya63 noted, the update did this for me too.

    The ‘/ issue comes up in other areas too, for example in a form, if you have “there’s” it shows “there’/s”.

    @vancleave8888
    My 4100+ emails took 20 hours. And all bounced back as failed delivery – including one to myself (unquestionably a valid address in use daily).

    I’m giving up and off to explore other (paid) email services as this one has become a huge let-down. Too clunky, too many issues, not intuitive, silly (and mis-spelled) menus, unreliable.

    Plugin Contributor Nirav Mehta

    (@niravmehta)

    @antya63 What’s the hourly limit for number of emails on your setup? Plugin will respect that limit to avoid issues with hosts that have a hard limit on emails.

    @vancleave8888 That is indeed problematic. Will do further review on our side. But if you can provide any additional details to help diagnose, it will be super useful.

    Thanks.

    My hourly limit is 400. I set the plugin limit as 350 to be on the safe side. Just tested sending a new post notification to a test group/list of only 2 email addresses – both mine, both valid.
    Report shows completed, yet neither of those emails have been received.

    alessandrovizzino

    (@alessandrovizzino)

    “Select active/inactive and creation new Post notification don’t work” – can you please clarify that a bit further?”

    “Campaigns” section>”Create Post Notification” button>window “Campaigns>New Post Notification”: SAVE doesn’t work. Likewise, it doesn’t even work to change active/inactive to a “Post Notification” string already created. I hope it is clear now.

    I have the same problem after upgrade. No notification is sent. Status In Queue and for days!! and still not sent. How to downgrade?
    /clausen, dk.

    My blog is new, so we’re talking less than 100 emails total–most get my posts via social media. Still, that’s no excuse for my emails not going out.

    Here we are, nearly 10 hours after my post this morning, and no notice has been sent.

    This worked fine for 11 months. Then the new “update” came. And here’s where we’re at.

    Good God, roll this back until you can test a beta. Emails on posts not being sent, widget vanished, reinstalled widget cant remove labels from fields. Why do I need field labels when the fields you have them grayed out inside?

    Right. Beta test more and roll this baby back.

    It’s bugtastic.

    borisj

    (@borisj)

    The issue with no “Post Notification” to be sent may be related to the categories. I just created a test “Post Notification” with only one category selected. This worked – eMail is in the queue according to the “Reports” page.

    There seems also to be an issue with category names containing special characters or spcaces at the end/beginning of a category name.

    Maybe this is because how the categories are now stored in the database

    Old (wp_es_notification)
    ##[CATEGORY NAME1]## — ##[CATEGORY NAME2]## — ##[CATEGORY NAME3]## — ##[CATEGORY NAME4]##

    New (wp_ig_campaigns)
    ##[CATEGORY NAME1]##[CATEGORY NAME2]##[CATEGORY NAME3]##[CATEGORY NAME4]##

    An other issue related to “Post Notification” in my case is that when I create or modify them. When I save the newly created or modified notification then it seems to be that nothing is saved. Sometimes all categories are unchecked. I have to reload the page to see the saved/modified parameters.

    Further I realized that is not possible to scroll the page if I am on the following pages:

    Settings > Email Sending
    Settings > Security

    When I updated the plugin my error log showed the following message:

    [02-Mar-2019 14:12:27 UTC] WordPress database error Table ‘d00ceecb.wp_ig_mailing_queue’ doesn’t exist for query SELECT * FROM wp_ig_mailing_queue WHERE status IN (‘Sending’, ‘In Queue’) ORDER BY id LIMIT 0, 1 made by do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, ES_Cron->handle_cron_request, ES_DB_Mailing_Queue::get_notification_to_be_sent

    Further I got the following message multiple (60+) times (this may have been resolved with the last update)

    [02-Mar-2019 14:58:44 UTC] Array
    (
    [form_id] => 1
    [name] => Updates & Newsletter
    [af_id] => 1
    [desc] =>
    [name_visible] => yes
    [name_required] =>
    [list_visible] => yes
    [list_required] => yes
    [lists] => Array
    (
    [0] => 1
    [1] => 2
    )

    )

    Thanks,
    Boris

    borisj

    (@borisj)

    Btw. I just rolled back to 3.5.18. Now I like the plugin again 🙂

    Is it save/recommended to delete the database tables of the new version?

    When looking at the old version I realized that you have the options to Check-/Uncheck All categories in the “Post Notification”. You don’t have this in the new version. May be useful to add it to the new version, too.

    Sunny regards from Germany,
    Boris

    ronsrace

    (@ronsrace)

    @borisj How did you rollback to that version? Where can I find it? thx!

    borisj

    (@borisj)

    @ronsrace Here is the How-to do the rollback https://wordpress.org/support/topic/rollback-to-email-subscribers-3-5-18/

    but be aware of problems that can come up with that rollback https://wordpress.org/support/topic/roll-back-to-3-5-18-error/

    Instead of rolling back you may first try to update to Version 4.0.3 which was just released 30 minutes ago.

    • This reply was modified 1 year ago by borisj.
Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Issues after 4.0.2 upgrade’ is closed to new replies.