WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Issues After 1.1.0 Update

[Resolved] Issues After 1.1.0 Update

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author codebycarter
    Member

    @codebycarter

    Hey akalatheory,

    Sorry about that, problems with subversion. Please download the plugin again and overwrite the files manually or deactivate and delete the plugin then reinstall but only if you don’t need to save anything as doing it this way will erase all your data.

    Let me know if you need any help with this I can manually overwrite the files for you without you losing any data.

    Thanks

    akalatheory
    Member

    @akalatheory

    Ok that fixed the role permissions and tool pages. The forum page is still showing up blank Dx

    http://www.akala.us/forums/

    Should I try deleting and re-installing?

    Plugin Author codebycarter
    Member

    @codebycarter

    You might have updated with the first invalid update which used different filenames, you could try deleting and reinstalling that should do it.

    If not add this line to wp-bulletin-board/wp-bb.php between <?php and ?>

    error_reporting(E_ALL);

    That should then display a message on the forum page, copy and paste that here. It is likely it’s using an incorrect filename in your theme folder / wpbb-template.php or wpbb-template.php doesn’t exist.

    akalatheory
    Member

    @akalatheory

    Neither did anything. Just the same blank page on the forums.

    http://www.akala.us/forums/

    Now if I go into the dashboard and manually click the forum I can see it (though no errors show, despite adding the code you told me to).

    http://www.akala.us/forums/?forum=2&current_page=1

    Plugin Author codebycarter
    Member

    @codebycarter

    Would you be able to setup a temporary admin account for me so I could take a look at this? My email’s me@codebycarter.com

    Thanks

    akalatheory
    Member

    @akalatheory

    Done. Password should come to your email obviously (: Thank you for your help!

    DustinRyan
    Member

    @dustinryan

    I’m running a very important website for the leading organization on Computer Ethics. We use your forum system for students to post discussions. A class has a final discussion due ASAP and your update broke the forum with this error:

    Warning: require_once(wpbb–index.php) [function.require-once]: failed to open stream: No such file or directory in /u2/www/htdocs/scsu/organizations/rccs/wp-content/plugins/wp-bulletin-board/php/wpbb-forum.php on line 409

    Fatal error: require_once() [function.require]: Failed opening required ‘wpbb–index.php’ (include_path=’.:/opt/csw/php5/lib/php:/u2/www/htdocs:/u2/www/htdocs/scsu/includes’) in /u2/www/htdocs/scsu/organizations/rccs/wp-content/plugins/wp-bulletin-board/php/wpbb-forum.php on line 409

    Please advise. We can’t afford to lose data and need help ASAP so the students can submit their finals.

    akalatheory
    Member

    @akalatheory

    I think I’m going to switch to bbPress. It seems to work without any flaws at all. :/ Good luck to you, DustinRyan.

    Plugin Author codebycarter
    Member

    @codebycarter

    DustinRyan,

    Sorry about that. I see the problem, didn’t see it myself as I’m using the default permalink settings at the moment.

    Open wp-bulletin-board/php/wpbb-forum.php line 409.

    Change

    require_once('wpbb--index.php');

    To

    require_once('wpbb-index.php');

    Sorry to hear that akalatheory. I haven’t yet received an email from you. Let me know if you change your mind.

    Thanks.

    DustinRyan
    Member

    @dustinryan

    Thank you for the quick response. Your solution worked perfectly. Many students and my boss can rest easy, now.

    DustinRyan
    Member

    @dustinryan

    Uh oh, looks like I spoke too soon. I see this error when viewing a topic now:

    WordPress database error: [Table ‘rccs2.wp_wpbb_topics_unread’ doesn’t exist]
    SELECT read FROM wp_wpbb_topics_unread WHERE author = 1 AND id = 2;

    WordPress database error: [Table ‘rccs2.wp_wpbb_topics_unread’ doesn’t exist]
    INSERT INTO wp_wpbb_topics_unread (id,author,read) VALUES (‘2′,’1′,’1’)

    Plugin Author codebycarter
    Member

    @codebycarter

    Try deactivating then activating again that should create the table for you, it’s possible with the muddle with the updates that something was missing and it didn’t create itself.

    If that doesn’t work, would you be able to email me with an admin login? I’ll be able to add some code to try and create the table from wordpress and see what if any the errors are. My email is me@codebycarter.com

    Thanks

    DustinRyan
    Member

    @dustinryan

    Will deactivating delete all of my settings and posts? There are graded submissions for students that we must keep for professors to view.

    Plugin Author codebycarter
    Member

    @codebycarter

    No you can safely deactivate the plugin at any time it will save all your data. It will only delete your data if you deactivate and then delete the plugin completely 🙂

    DustinRyan
    Member

    @dustinryan

    Thank you that worked.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Issues After 1.1.0 Update’ is closed to new replies.