WordPress.org

Forums

[resolved] Issues 3.9.1 Stock OS X Mavericks Server PostgreSQL (5 posts)

  1. bsmithline
    Member
    Posted 1 year ago #

    I have tried to update to 3.9.1 after update completes from the WP-ADMIN "UPDATE-NOW" the screen just goes to an blank white screen. I do not want to add MySQL. I just want to use the stock Apple install [ KISS ]. Up to the 3.9.1 version I was able with no problem use the "UPDATE-NOW" with no problems.

  2. Sandy
    Member
    Posted 1 year ago #

    To the best of my knowledge MySQL is the only supported database for WordPress.

    See http://codex.wordpress.org/Using_Alternative_Databases for more information on this subject.

  3. bsmithline
    Member
    Posted 1 year ago #

    To bad if that is now true. Up to WordPress 3.8.1 it has worked with the drop-in PostgreSQL for WordPress (PG4WP). It could be that a change was made so that this drop-in does not work with 3.9.1, and again if so to bad. If Apple had not changed from MySQL to PostgreSQL in its server product this may not have been an issue.

    If I can no longer update/upgrade WordPress I may have to look to other options.

  4. Sandy
    Member
    Posted 1 year ago #

    Is this the plugin you were using?

    http://wordpress.org/plugins/postgresql-for-wordpress/

    It looks as though the author of that plugin has not updated it in sometime. So you are likely right I would say if it was working with 3.8.1 but not with 3.9.1 that something has changed that caused this plugin to not longer function.

    The plugin would have to be updated to be compatible with 3.9.1

  5. bsmithline
    Member
    Posted 1 year ago #

    Yes it is the plugin I am using. Found a post on the WordPress site that solved my problem.

    https://vitoriodelage.wordpress.com/2014/06/06/add-missing-wpsql_errno-in-pg4wp-plugin/

    Hope this will help other who just want to KISS and maintain stock version of the OS X server product.

Topic Closed

This topic has been closed to new replies.

About this Topic