Support » Plugin: WooCommerce payment plugin - Novalnet AG » Issue WooCommerce 3.6.1

  • Resolved mensmaximus

    (@mensmaximus)


    Since the update to WooCommerce 3.6.1 no payments are possible anymore.

    The error message is:
    Warning: include(): Failed opening ‘/www/htdocs/wp-content/plugins/woocommerce/templates/render-redirect-form.php’ for inclusion (include_path=’.:/usr/share/php:..’) in /www/htdocs/wp-content/plugins/woocommerce/includes/wc-core-functions.php on line 249

Viewing 11 replies - 1 through 11 (of 11 total)
  • For those in need for a solution until Novalnet will post an update, here is what you need to do.

    This applies only if you use WooCommerce Vesion 3.6 or above in conjunction with the Novalnet Plugin Version 11.2.12 or below.

    1. Connect to you websever using ftp
    2. Navigate to the directory /wp-content/plugins/woocommerce-novalnet-gateway/includes
    3. Copy the file wc-novalnet-functions.php to your local computer
    4. Open the file with a text editor (NOT Word!!, use something like notepad++)
    5. Locate the function wc_novalnet_load_template() arround line 256
    6. Replace

    if ( function_exists( 'wc_get_template' ) ) {
            wc_get_template(
                $file_name, array(
                'default_path' => $directory_path,
                $content_name  => $contents,
                )
            );
    

    with

    if ( function_exists( 'wc_get_template' ) ) {
        /*
            wc_get_template(
                $file_name, array(
                'default_path' => $directory_path,
                $content_name  => $contents,
                )
            );
        */
            wc_get_template( $file_name, array( $content_name  => $contents ), '', $directory_path  );

    7. Save the file
    8. Transfer the file back to you server using ftp to the same location (/wp-content/plugins/woocommerce-novalnet-gateway/includes)
    9. Payments will work again

    The changes in version 11.2.13 are still not correct:

    wc_get_template(
                $file_name, array(
                'default_path' => $directory_path,
                $content_name  => $contents,
                ),'',$directory_path
            );

    As you can read from the conversation at github with the woocommerce lead developers “$args is documented as being what is passed to the template. It does not control which template should be loaded. That would also be a bug.”

    Please remove ‘default_path’ from the $args array. The default_path gets only passed as last argument .

    It is nearly 3 weeks now I reported this issue and still no answer. Please remove ‘default_path’ from the array because it is and was not supported at all. This may cause more issue with future woocommerce version.

    Version 11.2.14 solved the issue.

    The Novalnet payment plugin is only supporting Woocommerce 3.5.7.
    It is not recommended to use with woocommerce 3.6.X
    That’s why our company is waiting with the update.

    • This reply was modified 7 months, 2 weeks ago by IRM.
    • This reply was modified 7 months, 2 weeks ago by IRM.
    • This reply was modified 7 months, 2 weeks ago by IRM.
    Plugin Author Novalnet AG

    (@novalnet)

    Dear @irm89, dear Mr. Ivo Ralf Müller,

    The Novalnet payment plugin is only supporting Woocommerce 3.5.7.
    It is not recommended to use with woocommerce 3.6.X
    That’s why our company is waiting with the update.

    I don’t know where you got this information from, because at the time you posted this, our plugin already supported WooCommerce 3.6.5. In the meantime, we have also released another update and today the plugin supports WooCommerce 3.7.0.

    If you have any difficulties please contact us at support@novalnet.de and we will be happy to assist you.

    Novalnet Support Team

    • This reply was modified 4 months, 3 weeks ago by Novalnet AG.

    @novalnet This information comes from the plugin itself.
    Version 11.2.14 does not support Woocommerce version 3.6

    The warning also came on the backend. (Plugin Page: Before updating Woocommerce)

    if that’s not true then the developer has made a mistake.

    See: https://woocommerce.wordpress.com/2017/08/28/new-version-check-in-woocommerce-3-2/

    • This reply was modified 4 months, 3 weeks ago by IRM.
    • This reply was modified 4 months, 3 weeks ago by IRM.

    @irm89 11.2.14 is outdated. 11.2.16 works well with WooCommerce 3.7.0. And 11.3.0 should work as well.

    Plugin Author Novalnet AG

    (@novalnet)

    Lieber Herr Müller,

    bitte installieren Sie immer unsere Plugin-Updates und nutzen Sie die neueste Novalnet-Plugin-Version. Dies ist aktuell Version 11.3.0. Bitte führen Sie das Update direkt in Ihrem WordPress durch.

    Sehr gern stehen wir stehen Ihnen für alle weiteren Fragen zur Verfügung.

    Bitte wenden Sie sich hierzu direkt an unseren Kunden-Support unter support@novalnet.de.

    Ihr Novalnet Support Team

    Alles wurde schon längst aktualisiert. Hier ging es um ein Beitrag der vor 2-3 Monaten aktuell war. Da gab es nur Version 11.2.14. Ich habe nur auf die Antwort von @novalnet geantwortet, dass diese Version kein offiziellen Support hatte laut Plugin.

    • This reply was modified 4 months, 3 weeks ago by IRM.
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.