Support » Plugins and Hacks » Issue with update

Issue with update

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author James Koster


    I’m not seeing any empty quotation marks. Did you resolve this?

    I am using an older version of the plugin, I have updated to the new version on this website http://jarvisjohnson.s.strategiesuk.net/.


    Same problem here as http://jarvisjohnson.s.strategiesuk.net/


    there are paragraphs added before and after the real quote .. which get styled as quotes .. so we get 2 blank quotes bubbles before and after the real one…

    The updated version of the plugin on 3.8.3 of WordPress.

    Change line 145 from:
    $content = apply_filters( ‘woothemes_testimonials_content’, apply_filters( ‘the_content’, get_the_content() ), $post );


    $content = apply_filters( ‘woothemes_testimonials_content’, get_the_content(), $post );

    i.e. basically remove the apply_filters from the_content. There is need of this sometimes, but this will work as a quick fix for you.

    Plugin Author James Koster


    You should probably use the woothemes_testimonials_content filter to do that 🙂

    I’d be interested to see why this happened though, I suspect it was something to do with the actual testimonial content. I can’t investigate that without a log in though.

    Thanks for the replies, dodg’s method seems to have fixed the issue.

    So this is still happening. With the new version (1.5.3) the line in question of course has moved:

    Line 149
    Replace from:
    $content = apply_filters( ‘woothemes_testimonials_content’, apply_filters( ‘the_content’, get_the_content( __( ‘Read full testimonial…’, ‘our-team-by-woothemes’ ) ) ), $post );

    $content = apply_filters( ‘woothemes_testimonials_content’, get_the_content( __( ‘Read full testimonial…’, ‘our-team-by-woothemes’ ) ), $post );

    Essentially I am removing the the_content filter, which of course isn’t clever.

    I tried using the woothemes_testimonials_content but couldn’t get what I wanted.

    I’ve found the issue though, and its not to do with the vanilla plugin. I had this code in my functions:
    function limestreet_woothemes_testimonials_item_template( $tpl, $args ) {
    if ( ‘individual’ == $args[ ‘category’ ] ) {
    $tpl = ‘

    $tpl .= ‘<p>%%TEXT%%</p>’;
    $tpl .= ‘<cite class=”individual-testimonial-author”>%%AVATAR%% %%AUTHOR%%</cite>’;
    $tpl .= ‘

    } else {
    $tpl = ‘<div class=”company-slider-item”>’;
    $tpl .= ‘%%AVATAR%%’;
    $tpl .= ‘</div>’;

    return $tpl;
    add_filter( ‘woothemes_testimonials_item_template’, ‘limestreet_woothemes_testimonials_item_template’, 10, 2 );

    Basically, already effecting the inner text of the testimonial – adding some more <p>’s.

    Youve got this style:
    .individual-testimonial p { … }
    to denote how I testimonial should look. Why not give this a class to stop people adding extra paragraph tags that effect the testimonial.

    .individual-testimonial p.testimonial_content

    Then obviously moving that class into the markup as well. Would resolve all conflicts like this.

    Hopefully this helps clear up the problem

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Issue with update’ is closed to new replies.