Support » Plugin: Plugin Name: Device Theme Switcher » Issue with Translated versions of WordPress

  • Resolved adrianosg

    (@adrianosg)


    Hi,

    I tried to install the plugin to use with a PT_BR version of WordPress.

    The plugin is installed but we cannot access the Settings page.

    After trying to find the error and doing some debugging we found that commenting the following lines prevented the error.

    $dts_cookie_lifespans = array(
    array(‘value’ => 0, ‘text’ => _(“When the browser is closed (Default)”)),
    array(‘value’ => 900, ‘text’ => _(“15 Minutes”)),
    array(‘value’ => 1800, ‘text’ => _(“30 Minutes”)),
    array(‘value’ => 2700, ‘text’ => _(“45 Minutes”)),
    array(‘value’ => 3600, ‘text’ => _(“60 Minutes”)),
    array(‘value’ => 4500, ‘text’ => _(“75 Minutes”)),
    array(‘value’ => 5400, ‘text’ => _(“90 Minutes”))); ?>
    file: calss.wp-admin.php //line 155

    We believe that since these are not found in the language files the error is ocurring.

    https://wordpress.org/plugins/device-theme-switcher/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author James Mehorter

    (@jamesmehorter)

    Thanks for reporting

    By PT_BR, do you mean that you’re running WordPress for Brazilian Portuguese?

    Plugin Author James Mehorter

    (@jamesmehorter)

    Version 2.9.0 released 12/18/2014 contains a *.pot file for help with internationalization. This allows users like yourself to contribute translations to the plugin if you so desired. Feel free to reach out to me at jamesmehorter@gmail.com if you’d be interested in providing English to Portuguese translations.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Issue with Translated versions of WordPress’ is closed to new replies.