Support » Plugin: Yoast SEO » Issue with the Twitter Card

  • Resolved csbiswal

    (@csbiswal)


    Hi,

    I’m Using Yoast’s Free Plugin on my site https://orissadiary.com

    Earlier things was fine, My posts are auto posted to Twitter via Jetpack and The Large Image with summery was appearing on the Twitter feeds.

    Now, The Tweets are auto posting in the Twitter and FB, Everything is fine with FB but in Twitter no image is appearing on tweets since last 2-3 days. I have also tested in Twitter card but it’s showing one error, Saying “INFO: Page fetched successfully
    INFO: 21 metatags were found
    INFO: twitter:card = summary tag found
    ERROR: Internal error (Card error)”

    Please check this Twitter card error here: https://prnt.sc/ustfid

    Also See, how tweets are appearing: https://prnt.sc/ustfxq

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Per your screenshots, you are using the Twitter page URL in the Twitter card validator instead of your site URL. You’ll need to use your site URL in the Twitter card validator to run the test.

    That said, we have tested one page https://orissadiary.com/odisha-khurda-district-reports-638-new-covid19-cases-today-tally-mounts-to-39558/ from your site by using the Twitter card validator and everything seems fine but the image isn’t showing on there which is very odd.

    Can you please confirm whether you have specified an image from the relevant page Yoast SEO meta box Twitter (tab)? If not, can you please specifically add an image on the relevant option and run the relevant test again by using the Twitter card validator to see whether this resolves the issue for you?

    Thread Starter csbiswal

    (@csbiswal)

    Thank you for your reply.

    https://orissadiary.com/odisha-kendrapada-district-reports-103-new-covid19-cases-today-tally-mounts-to-5500/

    I also run the above URL in the Twitter card validator but No image appearing.

    I simply Give a Post title, Write the description and upload featured image and publish the post. The Tweeter feed automatically shows the featured image in the tweet now, that is not happening.

    Please guide me to fix this.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand you don’t assign an image specifically for Twitter but you add a featured image instead. However, we still want you to please add an image in the Yoast SEO meta box Twitter (tab) to see whether this resolves the issue for you.

    Can you please confirm this?

    Thread Starter csbiswal

    (@csbiswal)

    Thank you for your Reply Md Mazedul

    Yes, Adding A photo in Twitter Tab of Yoast Meta Box helps in photo appearing in in Twitter. But Earlier it was not required.

    One more thing I’m also noticing Suppose a particular post is not coming up with photo in twitter and i run that in Card validator 3-4 times, then the photo apereas in the card validator as well as the Twitter tweet.

    I think this is an issue with the plugin.

    KIndly Help me

    THanks
    CHandra

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @csbiswal

    Since Yoast SEO has outputted all the required Open Graph meta tags on the page source code of your given post this particular issue doesn’t seem to be related to our plugin. According to Twitter documentation, images referenced in a Card are also cached based on URL. This often causes images to not update.

    Refreshing the Twitter Card Validator multiple times clears the cached URL.

    Further, please refer to Twitter’s documentation about Refreshing a Card in a Tweet when such a problem occurs.

    Thread Starter csbiswal

    (@csbiswal)

    Hi Suwash,

    Thanks for responding.

    My concern is this is a news website and each day 50+ post are being added.

    Why this Twitter preview problem is happening now? Earlier it was fine. Manually refreshing Twitter card for each post is not possible.

    Hope you understand my concern.

    Thanks
    Chandra

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi Chandra,

    We can definitely understand if it’s not just one post. It looks like Twitter isn’t displaying the cards from your site despite Yoast SEO showing the required tags, so we’re not able to say why Twitter isn’t working as expected.

    You can try to get more information or recommendations by submitting a support request with Twitter.

    Thread Starter csbiswal

    (@csbiswal)

    Thank you very much everyone for your time and responding to my query.

    The issue was with the twitter and now they have resolved it.

    Best
    Chandra S

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Issue with the Twitter Card’ is closed to new replies.