Support » Plugin: Newsletter » Issue with subscription WPML

Viewing 7 replies - 1 through 7 (of 7 total)
  • BSR

    (@biblestudyradio)

    Additional info: Not sure if it is related. Under Settings -> General Settings -> Basic Settings -> Dedicated Page. When I changed the dedicated page to the Chinese newsletter page it also changed the English. Currently both pages have the same short code -> [newsletter]

    Plugin Author Stefano Lissa

    (@satollo)

    Hi, that setting is NOT language dependant. Just select the default language page you created and then Newsletter will ask WPML the right translated page to be used when a message is shown.

    Probably we should consider another approach about settings on that page.

    Stefano.

    BSR

    (@biblestudyradio)

    The main problems are the 2 that are listed. One is user won’t be able to see the confirmation page in another language and the other is the email for the other language is not sent.

    Thanks.

    Plugin Author Stefano Lissa

    (@satollo)

    Uhm, I’m not able to reproduce your settings and so the bug. could we try to create a step by step case?
    On main settings you should be able to select the dedicated page in your default language, for example English. On that page there is only the [newsletter] shortcode.
    That page has a connected page which is the chineese translation, for example with a different title, and contains always the [newsletter] shortcode.

    Is that correct? Can you share your blog address to check together?

    Thank you, Stefano.
    ps: write me at stefano@thenewsletterplugin.com, if you prefer, so we can proceed quickly.

    BSR

    (@biblestudyradio)

    Thank you Stefano. I have sent you via email.

    In all the sections of the Newsletter I see this on top of admin:

    “You are configuring the language en. Switch to “all languages” to see every options.”

    However, in the Settings section, that message is not there.

    As mentioned earlier I tried to change the Dedicated page to the Chinese version which has identical content [newsletter] shortcode. The only difference is the title. After I click save, it saved it and but it also changed the English dedicated page as well.

    BSR

    (@biblestudyradio)

    Hi Stefano,

    Are you able to fix the issue with subscription for the other language with the minimal shortcode and the “?lang=zh-hans” query? Thank you.

    Plugin Author Stefano Lissa

    (@satollo)

    Should be solved on version 5.6.2.

    Stefano.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Issue with subscription WPML’ is closed to new replies.