Support » Plugin: jQuery Manager for WordPress » Issue with Slider Revolution

  • Resolved titsmaker

    (@titsmaker)


    Love your plugin! But when it’s activated I am having slight problems with Slider Revolution when it’s JS is deferred. Content after the slider is loaded before the slider, then the slider appears which causes content to jump down. Awgh! I thought it is caused by deferring, but after deactivating your plugin problem was solved. There’s an error message in Chrome console indicating that placeholder was not created due to problems with JQuery – https://prnt.sc/oa8iw4

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi @titsmaker

    It could be that slider revolution doesn’t support the latest jQuery version.

    I will check this out. What’s the URL of your website? So that I could take a look at it.

    Kind regards,
    Remzi

    @remzicavdar I tried it with classic JQuery 1.12.4 and got the same results. My website is https://artifactoria.com

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    @titsmaker

    I understand what the issue is, I have looked at your website. You probably use a very aggressive caching / minification plugin.

    I found that your jQuery version is bundled with all other scripts and defer, some themes and/or plugins don’t support this option. That’s why most caching and minifier plugins give you the option to exclude defering jQuery.

    <script data-optimized="1" src="https://artifactoria.com/min/9116d.js" defer=""></script>

    I will mark this ticket as resolved, because you should exclude jQuery being defered and if this is not possible I could recommend you an other caching plugin, for example: https://wordpress.org/plugins/wp-fastest-cache/

    Kind regards,
    Remzi

    • This reply was modified 8 months, 4 weeks ago by Remzi Cavdar.

    I am sorry. I was getting this issue with both LiteSpeed and Autoptimize. Both plugins had “exclude JQuery” option activated. Further investigation revealed that the option just didn’t work. When I manually added path to JQuery file provided by your plugin to exclusions the problem was solved. So the question is whether the problem appeared due to their implementation of “exclude JQuery” options or the way you substitute Jquery.

    Autoptimize uses the WordPress core path to jQuery to exclude, if your jQuery is loaded from elsewhere, you will indeed need to adapt the exclusion 🙂

    frank (ao dev)

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    Hi guys @titsmaker and @optimizingmatters

    By default the plugin loads jQuery and jQuery Migrate from the plugin assets directory:
    Your hosting directory -> wp-content/plugins/jquery-manager/assets/js <- here are all the .js files stored.

    This would be:

    wp-content/plugins/jquery-manager/assets/js/jquery-3.4.1.min.js
    wp-content/plugins/jquery-manager/assets/js/jquery-migrate-3.1.0.min.js

    I think you should only exclude jQuery, I did some test and it’s safe to defer jQuery Migrate, not jQuery.

    @optimizingmatters How should he exclude this in the settings? Could you help him further?

    Kind regards,
    Remzi

    • This reply was modified 8 months, 4 weeks ago by Remzi Cavdar. Reason: Grammar

    I think he already did @remzicavdar

    When I manually added path to JQuery file provided by your plugin to exclusions the problem was solved.

    😉

    Plugin Author Remzi Cavdar

    (@remzicavdar)

    @optimizingmatters Okay, I didn’t saw that. Thank you for clarifying this.

    Kind regards,
    Remzi

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Issue with Slider Revolution’ is closed to new replies.