Support » Networking WordPress » Issue with redirect – restart server only helps

  • Resolved tottaz

    (@tottaz)


    I have an issue with that my multi site gets into a redirect loop – not sure at what condition it happens at.

    I have setup my site as sub-domain MU – my main domain is torbjornzetterlund.com with two sub-domains thelonelycylsit.org and cycletrippin.org – they show up the domain mapping as thelonelycyclist.torbjornzetterlund.com and cycletrippin.torbjornzetterlund.com

    The problem is that once a day randomly torbjornzetterlund.com goes into a redirect loop. I have followed the advice that I have found in these forums. None of them have resolved the problem. I have checked my Permalinks – changed saved changed back saved – that worked for a little while, the problem came back.

    The only thing that seems to resolve the problem is to restart the server, is there any logs or debug mode that can be switched on to track what happens prior to the problem occurs.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    I have checked my Permalinks – changed saved changed back saved – that worked for a little while, the problem came back.

    You have a plugin or a theme setting that’s messing with permalinks.

    What plugins are you running on the main site OR network wide?

    On the main site I’m running Sympagrid – I also have mystile and Storefront from Woocoomerce and I have Fundify.

    I also installed for the Chrome browser the Live HTTP Headers plugin, so next time it happens I can watch the http:// headers to see what redirects is taken place.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It’s not going to be that.

    It’s rather literally your DB settings are being changed by ‘something.’ Saving the permalinks resets them properly, which is why it fixes it.

    It did not work with the HTTP Headers did not tell me.

    It start happen more frequent – on a daily basis – the only thing that helps is to restart. You mentioning the db, would it be worthwhile to investigate the mysql log?

    So this ‘something’ could it be a theme or a plugin, if that is the case is it all about elimination to see what happen.

    I do run the hyperdb plugin on a replicated mysql db, I will start there and see how it goes.

    Just an update, my problem went away when I removed the hyperdb plugin – it is either an issue with the hyperdb plugin or the configuration that I had made for hyperdb.

    For know the redirect issue is gone.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Issue with redirect – restart server only helps’ is closed to new replies.