Support » Plugin: Cyr-To-Lat » Issue with products in admin

  • Resolved prokreeger

    (@prokreeger)


    After update to v5.2.0, products section and product preview didn’t work in admin.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author kaggdesign

    (@kaggdesign)

    Which products? WooCommerce? Where do you name product preview? What is the URL in admin?

    And, essential. Do you have WPML installed? If not, your question is not related to 5.2.0.

    Thread Starter prokreeger

    (@prokreeger)

    URLs that caused issue in admin:

    I’m using WordPress 5.8, WooCommerce 5.5.2 and the latest WPML.

    Plugin Author kaggdesign

    (@kaggdesign)

    I have no problem with the same latest versions of plugins and similar links.

    What is your issue? What does it mean – “do not work”? What do you see?

    Please deactivate all other plugins except WooCoomerce, WPML and Cyr2Lat and explain what I have to do to reproduce the problem on a test site.

    grayru

    (@grayru)

    It seems my problem is the same.
    After upgrade plugin generates MySQL error

    2021-07-28 15:58:18.444988 [NOTICE] [2521] [217.73.0.0:65185:HTTP2-15#wordpress] [STDERR] ........ ............ WordPress .................... ............ You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 3 .. .......... .... ............ SELECT slug FROM wp_terms t LEFT JOIN wp_term_taxonomy tt
                                                            ON t.term_id = tt.term_id
                                                            WHERE t.name = 'alc' AND tt.taxonomy IN (), ...................... do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, wvs_add_product_taxonomy_meta, wc_attribute_taxonomy_name, wc_sanitize_taxonomy_name, sanitize_title, apply_filters('sanitize_title'), WP_Hook->apply_filters, Cyr_To_Lat\Main->sanitize_title

    Latest versions of WPML and Woocommerce.

    Disabling of your plugin fixes the issue.

    Thread Starter prokreeger

    (@prokreeger)

    I have deactivated all plugins except WooComerce, WPML and Cyr2Lat, but issue didn’t gone.

    When I click on the Products link in the Admin menu (see the picture below), the page goes into infinite loading until the server returns a timeout.

    https://i.ibb.co/Tqc33LW/27cd894d-358e-4e31-94a2-dd4d2f2af29f.png

    Issue is disappeared only when I am deactivating WPML or Cyr2Lat.

    Plugin Author kaggdesign

    (@kaggdesign)

    @grayru Thank you for the report, but it is a different issue. I have fixed this notice in the next version 5.2.1 to be released today.

    Plugin Author kaggdesign

    (@kaggdesign)

    @prokreeger Thank you for a more detailed explanation. I am not sure why it is going on. Please try to check with the latest version 5.2.1, which I have just released.

    Plugin Author kaggdesign

    (@kaggdesign)

    @grayru 5.2.1 released, please check.

    Thread Starter prokreeger

    (@prokreeger)

    With new update all works fine.

    Thank you for a fast and great support.

    Plugin Author kaggdesign

    (@kaggdesign)

    Thank you for your description of the problem. I was unable to reproduce it locally (and think it happens with a big number of products) but guessed the reason.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.