Support » Plugin: Posts in Page » Issue with posts in page with child theme

  • Hello:

    Great plugin! I’m having a small issue with your plugin: I’m using a child theme of the WP Bootstrap 4 and I’m trying to use a custom template (as per your instructions) but is not working exactly as you mentioned in your documentation:

    1. I created a folder “posts-in-page” in my child them and there I added my own templates, then referencing them in the shortcode as
    [ic_add_posts category='XXX' orderby='date' order='DESC' showposts='5' template='my_template.php'] but didn’t work
    2. the same custom template on the root of my child theme with the same shortcode and didn’t work either
    3. if I copy/paste “posts_loop_template.php” to my child theme’s root directory, it does work

    I actually checked on GitHub, and you are using get_stylesheet_directory to get the URI of the theme, so I checked on my code, and it dumps correctly my child theme’s URI.

    Any help will be appreciated.

    PS Thanks for your plugin

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Eric Amundson

    (@sewmyheadon)

    Hi @xuesolution,

    Thanks for the message. We’ll take a look at this and let you know if we have any questions.

    You’re using the latest version, 1.4.4, correct?

    Thread Starter Xue Jimenez

    (@xuesolution)

    Hello Eric

    Sorry about not posting some additional information:
    Wordpress
    5.4.1
    Posts-in-page
    v.1.4.4
    a few other plugins installed, but as far as I’ve seen no further incompatibilities:
    Contact Form 7 (5.1.7)
    Classic editor (1.5)
    Dynamic Featured Image (3.7.0)
    page-lists (5.2)
    WP-SCSS (1.2.5)

    I’ve already tried verifying for incompatibilities among them, but so far so good.

    In reading the documentation, since the results of line 345 are cached, I tried clearstatcache(); but it didn’t really help much.

    I added (just for testing)
    $template_file = get_stylesheet_directory() . '/posts-in-page/home-template.php';
    in class-page-posts.php, but didn’t work either…

    Thread Starter Xue Jimenez

    (@xuesolution)

    Hi Eric,

    In checking this specific error, I think I found something, but the question would be: how can I submit code for you to review? Is it just a git pull?

    Hi @xuesolution ,

    Thanks for describing the issue here.
    We found the bug here and will try to resolve it in the next plugin update.

    Regards,
    Ivycat Team

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Issue with posts in page with child theme’ is closed to new replies.