Support » Plugin: Admin Menu Editor » Issue with PHP 7.4 Function get_magic_quotes_gpc() is deprecated

  • Resolved harpo1984

    (@harpo1984)


    Hi,

    When using PHP 7.4 I get the following depreciated warning:

    Function get_magic_quotes_gpc() is deprecated

    I understand this is a warning but depending on what Admin page I am on in the backend, there is some considerable time added to database queries/page load times in the backend.

    Kind regards,

    Simon

Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes also seeing this – the warning message appears in the admin dashboard and gives further warnings from wordpress about ‘output before headers’.

    Plugin Author Janis Elsts

    (@whiteshadow)

    Thank you for the report. The plugin only uses get_magic_quotes_gpc() for backwards-compatibility with very old sites that still have magic quotes enabled. It looks like simply skipping that part of code if the PHP version is 7.4 or newer should be safe enough and also fix the warning. Please try this patched version:
    https://downloads.wordpress.org/plugin/admin-menu-editor.zip

    If the patch works, I’ll release it as an update.

    Hi @whiteshadow

    Problem solved with that patch!

    Sorry, I was off for the weekend.

    I tested it on a couple of sites.

    Thanks very much.

    Kind regards,

    Simon

    Plugin Author Janis Elsts

    (@whiteshadow)

    All right, I’ve released a new version that includes this patch.

    Hello! I am using version 1.9.3

    The get_magic_quotes_gpc deprecated warning seems still exists in the following files
    menu-editor-core.php line 3454
    might be in AjaxWrapper.php line 451

    For your reference

    Plugin Author Janis Elsts

    (@whiteshadow)

    Thank you for the report. The warning in menu-editor-core.php should have been fixed in version 1.9.3, but I did miss the instance in AjaxWrapper.php when I was fixing it. I’ll release a new version that fixes that one, too. You should see an update today.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Issue with PHP 7.4 Function get_magic_quotes_gpc() is deprecated’ is closed to new replies.