Support » Plugin: Onepager - One Page Builder » Issue with OnePager

  • Resolved bubumann43

    (@bubumann43)


    Hi,

    I have a issue with the onepager-plugi. If I create a new page and click on the button “Enable onepage”, never happens. The button is still “Enable onepage”, i get no error messasges and i have no new items.

    Where ist the mistake?

    Thank you for your help

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi,

    I have the same isssue as @bubumann43. Is it a compatibility’s problem with worpress 4.7.1 ?

    Thanks you

    dineshM

    (@dineshm)

    I sorted the issue. After you update to wordpress 4.7.1, the onepager will not enable in the wordpress Page editor. Until you click enable onepager, everything is fine with your created page. But once you click onepager button, it will revert to default page template, you will see that in sidebar. It won’t change to onepager template right from your page editor as that is the bug. You will need to go to your DB, find the Page ID and change wp_page_template to onepager(metakey), you will see “default” value is inserted there.

    This way you can atleast fix your broken working copy of the page created with onepager.

    • This reply was modified 8 months ago by  dineshM.

    Does not work:
    Made:
    UPDATE db_xxx.xxx_postmeta SET meta_value = ‘onepager’ WHERE xxx_postmeta.meta_id =1 LIMIT 1 ;
    Another possibility to get my onepager back?

    THX a lot

    Ah, got it, it’s ‘onepage.php’ instead of ‘onepager’

    Hi I too have the OnePager bug but I don’t understand how to fix it based on your comments to date. Could someone please walk me through it, I’m desperate to get my website back up.

    Thanks

    Hi,

    Seeing the same issue as mentioned in above comments or it’s different? Let me know, may be I can help

    Thanks

    Guys,I think this is the error you are getting and how to fix it.

    https://www.youtube.com/watch?v=lguaExcl5AY

    I solved it! I have wordpress 4.7.3 and OnePager would not enable on exisiting or new pages.

    Follow this tutorial to make it work.
    Go to your THEME FOLDER in WordPress, make a new file called onepage.php and paste the following text:

    <?php /* Template Name: OnePager */ ?>
    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset=”<?php bloginfo( ‘charset’ ); ?>”>
    <meta name=”viewport” content=”width=device-width, initial-scale=1″>
    <link rel=”profile” href=”http://gmpg.org/xfn/11″>
    <link rel=”pingback” href=”<?php bloginfo( ‘pingback_url’ ); ?>”>
    <title><?php wp_title(); ?></title>

    <?php wp_head(); ?>
    </head>

    <body <?php body_class(); ?> >

    <div class=”op-sections”>
    <?php the_content(); ?>
    </div>

    <?php wp_footer(); ?>
    </body>
    </html>

    Make sure you add the new file into the THEME FOLDER your site is using and it should work. Here’s the video link I found

    Link to file content:
    https://raw.githubusercontent.com/themexpert/onepager/develop/app/templates/onepage.php

    If a child theme is used, onepage.php have to be stored in the theme folder of the PARENT THEME.

    Thanks for Solution!

    Plugin Author themexpert

    (@themexpert)

    Hey Guys,

    We’ve a private Facebook group you can connect and network with professionals. All our free product supports are handled through FB group for better management.

    If you are interested, please join here https://www.facebook.com/groups/themexpert

    Thanks
    Parvez

    Where u guys able to see the changes in real time after they fixed the main problem? I made a lot of tests and for me and some other guys that is not working. Tks.

    Neither do I. Unfortunately, that page template has to communicate with Genesis Framework on my site. Did anybody figure out a genesis template for this plugin?

    Plugin Contributor nadimtuhin

    (@nadimtuhin)

    This issue is fixed with recent release 🙂

    Apparently not. I’m having the issue with WP 4.8.1. I created the onepager.php file as per instructions (and video) above but it still does not enable.

    If I change the template to onepager, it stays but selecting one of two templates (either “start blank” or “coporate 1” I get a pop-up message “Are you sure you want to insert this layout? This layout will replace your current layout”. If you select yes, it takes you to the front page with a 404 error.

    In short, there is no option to actually “build” the page.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.