Support » Plugin: WP Hide & Security Enhancer » Issue with MetaSlider

  • Resolved baga

    (@baga)


    If I activate WP Hide & Security Enhancer, then MetaSlider is broken, cannot load themes into modal window.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author tdgu

    (@tdgu)

    This should work fine, do you use the free MetaSlider plugin?

    Thanks for getting back.
    Yes the free version.

    Plugin Author tdgu

    (@tdgu)

    Can you ensure you didn’t blocked the JSON at WP Hide > Rewrite > JSON REST ?
    Also see other options, try to turn off.

    If still not working, can you send additional details on how to replicate the issue?

    That was it!
    I turned off “Block any JSON REST calls” and now MetaSlider themes are loaded correctly.

    Thanks a lot for your help!

    One more question, is there any option to hide Autoptimize generated files?

    Plugin Author tdgu

    (@tdgu)

    Per Autoptimize documentation, if you want to serve files from e.g. /wp-content/resources/aggregated_12345.css instead of the default /wp-content/cache/autoptimize/autoptimize_12345.css, add this to wp-config.php:

    define('AUTOPTIMIZE_CACHE_CHILD_DIR','/resources/');
    define('AUTOPTIMIZE_CACHEFILE_PREFIX','aggregated_');

    As alternative, the PRO version come with Map Urls module through which you can rewrite while directories and files.

    Thank you very much, it works like a charm!

    Hello again, should I change anything after last update? (Changelog says Autoptimize css/js cache and minify compatibility).
    Thanks

    Plugin Author tdgu

    (@tdgu)

    You can clear your site cache, just in case.

    Thanks

    Alright thanks a lot!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Issue with MetaSlider’ is closed to new replies.