Support » Plugin: WP Fusion Lite » Issue with Megamenu walker

  • Resolved nsinelnikov

    (@nsinelnikov)


    Hi guys,

    Could you fix your nav-menu walker class?
    wp-fusion-lite/includes/admin/class-admin-menu-walker.php :: line 63

    I found that you use 4 arguments for WP native hook ‘wp_nav_menu_item_custom_fields’.

    do_action( 'wp_nav_menu_item_custom_fields', $item_id, $item, $depth, $args );

    The right way is the using 5 arguments, which isn’t conflicted with WP native logic is:

    do_action( 'wp_nav_menu_item_custom_fields', $item_id, $item, $depth, $args, $id );

    See wp-admin/includes/class-walker-nav-menu-edit.php :: line 242

    Best regards,
    Thanks!

Viewing 1 replies (of 1 total)
  • Plugin Author verygoodplugins

    (@verygoodplugins)

    @nsinelnikov, yup, good catch.

    Actually we’ve removed the WPF_Admin_Menu_Walker entirely from the full version of WP Fusion, since it’s no longer necessary with WP 5.4.

    That change will be released in the next update of the Lite version as well.

Viewing 1 replies (of 1 total)
  • The topic ‘Issue with Megamenu walker’ is closed to new replies.