WordPress.org

Support

Support » How-To and Troubleshooting » Issue with Live Writer and Attaching Images on 2.8

Issue with Live Writer and Attaching Images on 2.8

  • I’m having a problem with attaching images to posts with Windows Live Writer and 2.8. I can write posts and put images in them. That works fine. But when I go over to my Media Library, it shows that the images I uploaded are not attached to any posts.

    This is a problem my theme generates previews for the post by looking through the attached images. If there are no attached images, then there will be no preview.

    The images attached fine in 2.7 but now that I’ve upgraded it to 2.8 they have stopped working. However, this is only an issue with Windows Live Writer. The images upload and attach fine with the WordPress uploader.

    Can anybody think of any fixes?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same problem.

    The theme I develop seriously relies of Media Library and without it is practically worthless.

    Any suggestions?
    Point being made is that when the post is sent to the WP 2.8 blog, WLW creates the necessary images and passes the control to WP, which creates thimbnailset al, but does not add it to the library.

    Any ideas?

    The problem now becoms The Problem since WLW is generall a better way to post, but now I have to go through all this silly TinyMCE…

    I wonder if this is related to my trouble here:
    http://wordpress.org/support/topic/282024?replies=1

    It’s just a guess, but it seems the attachment and attachment metadata functions have changed between 2.7 and 2.8.

    Nevermind – should have tested the theory before I spoke. My problem persisted with 2.7 so I can’t pass blame on a 2.8 bug 😛

    Good luck friends.

    I still cannot see that hapening.

    just in case this is the same bug with images and unsaved post I have tried to post a new entry and then add images to it – to no avail.

    I have also submitted the thing to bugtrac, however no response there..

    I am also seeing this behavior, my posts have images, but my preview has no thumbnails anymore. I haven’t found it yet but WordPress 2.8 seems to have changed the behavior of attachments and isn’t adding the image metadata to the post anymore if using xmlrpc solutions like WLW.

    You can of course add a ‘Custom Field’, in my case the [name] would be ‘Image’ and the [value] would be ‘http://url.to/my/image’, but this is based on phpthumb integration.

    Maybe a Dev could enlighten us on what/where was changed so we may try to correct this asinine behavior.

    Additionally, as I use WLW religiously, this is a game changer for me, I’m going back to 2.7.1.

    Here is an screenshot from my own dashboard with commentary of what’s happening via the WordPress Media Gallery.

    Just an update on this issue, this was broken with a change to the database schema in 2.8 with [ post >> post_parent ] being changed from ‘SIGNED bigint(20’) to ‘UNSIGNED bigint(20’). During the image upload the XMLRPC tries to set post_parent as ‘-1’, which fails with with the ‘UNSIGNED’ attribute. The regression is realized and will be fixed in 2.9.

    Temporary fix, open xmlrpc.php, around line 2272 you will find..

    $attachments = $wpdb->get_results( "SELECT ID, guid FROM {$wpdb->posts} WHERE post_parent = '-1' AND post_type = 'attachment'" );

    change to

    $attachments = $wpdb->get_results( "SELECT ID, guid FROM {$wpdb->posts} WHERE post_parent = '0' AND post_type = 'attachment'" );

    Hey, that worked. Thanks a bunch, cqrt.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Issue with Live Writer and Attaching Images on 2.8’ is closed to new replies.
Skip to toolbar