The Events Calendar
[resolved] Issue with IE and Placeholder text in calendar search (4 posts)

  1. supawiz6991
    Posted 1 year ago #


    When using IE, The placeholder text of "Search" is being searched when I click to the next month (Not actually trying to search). I get the following message:

    There were no results found for "Search" this month. Try searching next month.

    Please note: I didnt click the "Find Events" button but rather clicked "july" so I could see next months events. This issue occurs only in IE.



  2. leahkoerper
    Modern Tribe Support Rep
    Plugin Author

    Posted 1 year ago #

    Hi supawiz6991,

    I’m sorry you’re having trouble. Have you tried deactivating other plugins to look for a conflict, or switching to a default theme like Twenty Twelve? If you need help, please read this guide to testing for conflicts.

    If you can isolate this as an issue that's inherent to The Events Calendar, we'd be happy to look into it further. Unfortunately, we can't help troubleshoot conflicts here on the free forum. If you do find a conflict, you can try getting in touch with the developer of the theme or plugin and see if they can shed some light on the issue.

    Also, can you confirm what versions of WordPress, The Events Calendar, and IE you are using?


  3. supawiz6991
    Posted 1 year ago #

    I'm using IE 11, wordpress 3.9.1 and The Events Calendar 3.6.1.

    I'm familiar with this issue as it has affected other plugins such as connections. I can tell you that its not a theme issue.

    From my prior encounters with the issue, I was told its either something that developed in the new version of IE and/or something that changed in wordpress.

    Would you be able to tell me where I can remove the placeholder text in your code? I know 100% that the placeholder text is the issue as when its removed the issue goes away.


  4. Brook
    Modern Tribe Support Rep
    Plugin Author

    Posted 1 year ago #

    Howdy supawiz,

    The function which outputs placeholder text can be found here: http://docs.tri.be/Events-Calendar/source-class-TribeEvents.html#4211-4232

    Please note, in every other instance of this in the past it has been a theme issue. Changing themes to a default WP one has always fixed it. Was it perchance the theme developer that said it was not their problem? Usually it is the result of using an outdated or poorly designed placeholder polyfill in the theme.

    I just researched the issue and have found no one else experiencing this issue in IE11, with our plugin or otherwise. That is a strong indicator that this is your theme. You might contact the dev and request they make it IE11 compatible. Cheers!

    - Brook

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • The Events Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.