Viewing 15 replies - 1 through 15 (of 22 total)
  • I’m also having the exact same issue, and the same message right after the step it says it’s connected to Facebook.

    Would love to know the solution too.

    same here

    same here

    same here… and counting…

    Same here! I would really love to know how to fix it please!!!

    same

    Same issue. have tried multiple times. FB says all set, click next, then woocommerce says something went wrong. try again.

    Hey everybody. on the screen with the toggles… If you activate the toggle for “manage your business” it seems to work now.

    not sure why the default is off if it is required

    Thread Starter maragotti

    (@maragotti)

    Hi urbanangersusa, I tried but dont work 🙁

    jake33

    (@jacobabbey1)

    Same issue , here , I have tried , to enable the business role .
    its still not working .

    Steve

    (@skyvergesteve)

    Hey @maragotti,

    Thanks for contacting us about Facebook for WooCommerce! I am happy to help out 🙂

    We have a snippet that will give us some additional error information, which may give us a better indication as to what might be happening here. Can you please add the following snippet to your site and attempt to connect to Facebook again? If you aren’t familiar with adding custom code to your site, here is some information as to how to do it. Personally, I like the free Code Snippets plugin method.

    You can view the snippet here:

    add_filter( 'wc_facebook_connection_proxy_url', function() { return 'https://wc-connect-test.skyverge.com/auth/facebook/';} );

    Once the snippet is in place and you have had a chance to try to connect to Facebook again, would you please send a screenshot or text of any additional error messages that show?

    Cheers,

    Steve
    SkyVerge

    Steve

    (@skyvergesteve)

    Hey @jacobabbey1 @delibob @bootsnbourbon

    Thanks for reaching out about the plugin. I’m sorry to hear that you are experiencing an issue as well. Although you are seeing the same error message and having a similar experience with connecting to Facebook, it may or may not be the same issue, I’m afraid.

    Since you’re not the person who originally started this topic then, per the forum guidelines, would you please start your own topic? We’ll be more than happy to help there 🙂

    @urbananglersusa The solution you mentioned is correct in many cases of this error message, so it is certainly worth at try for any that have yet to change this setting. Facebook recently updated their settings to toggle “Manage your business” permission to Off by default. This needs to be set to On. You can check this Facebook setting by selecting Business Integrations > WooCommerce Extension V2 and toggling the Manage your business setting to the “Yes” position.

    https://cloud.skyver.ge/o0umOywP

    This can also be done during the setup process when you get to the What is WooCommerce Extension V2 allowed to do? portion of the setup process, you will see the option to toggle this to the On position.

    Cheers,
    Steve
    SkyVerge

    I couldn’t get it to work even by toggling the Manage Your Business switch. But then I tried the whole process in a new incognito window and it worked. Not sure if that will help someone else.

    Thread Starter maragotti

    (@maragotti)

    Hi @steve!

    Nothing, same error 🙁

    Steve

    (@skyvergesteve)

    Hey @maragotti ,

    Did you add the snippet that I sent along earlier? With the snippet in place, you will still receive the same error, but it should generate some additional information under the error. If you are seeing the error with additional text, can you please send another screenshot of the error?

    Cheers,

    Steve
    SkyVerge

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Issue with Fb integration’ is closed to new replies.