Support » Plugin: Clean Login » Issue with “Enable password complexity?” option

  • Resolved Hemant Arora

    (@hemantkumararora)


    First off, I want to congratulate and thank the “Clean Login” team for developing a very simple, light-weight, to-the-point, yet flexible login form plugin. It is a complete package! Thanks again.

    Coming to the issue, when I have the “Enable password complexity?” option enabled, I receive the following error:

    Warning: preg_match_all() expects at least 3 parameters, 2 given in [THE_WP_INSTALLATION_PATH]/wp-content/plugins/clean-login/clean-login.php on line 202

    Warning: Cannot modify header information – headers already sent by (output started at [THE_WP_INSTALLATION_PATH]/wp-content/plugins/clean-login/clean-login.php:202) in [THE_WP_INSTALLATION_PATH]/wp-includes/pluggable.php on line 1179

    Being a developer myself, I am aware this is a small issue with preg_match_all, but I would like to report and help an wonderful plugin get even better.

    Thanks guys! 🙂

Viewing 1 replies (of 1 total)
  • Plugin Author Alberto Hornero

    (@hornero)

    Hi Hemant,

    Thanks for you report. The third parameter for preg_match_all became optional from PHP 5.4.0. but before it’s mandatory.

    I’ve updated the code, and we are going to release today. Thanks,

    Alberto.

Viewing 1 replies (of 1 total)
  • The topic ‘Issue with “Enable password complexity?” option’ is closed to new replies.