Support » Plugin: Autoptimize » Issue with Custom Share Buttons with Floating Sidebar (csbwfs) plugin

  • Resolved florianmarianna

    (@florianmarianna)


    Hi,

    Autoptimize for some reasons changes the javascript of the share button links of the plugin CSBWFB. This might be something that came with one of the last updates as I didn’t have any issues in the past. I tried deactivating/activating autoptimize and when it’s deactivated the problem disappears.

    The original code of one share button is the following:

    <a href="javascript:" onclick="javascript:window.open('//www.facebook.com/sharer/sharer.php?u='+encodeURIComponent(location.href)+'&title='+encodeURIComponent(document.title)+'&jump=close', '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');return false;" target="_blank"><i class="csbwfs_facebook"></i></a>

    When autoptimize is activated, here is how this code is changed to:

    <a href="javascript:" onclick="javascript:window.open(" www.facebook.com="" sharer="" sharer.php?u="+encodeURIComponent(location.href)+&title=+encodeURIComponent(document.title)+&jump=close'," '',="" 'menubar="no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');return" false;"="" target="_blank"><i class="csbwfs_facebook"></i></a>

    Do you have any idea how to fix this?

    Thanks a lot in advance,

    Florian

Viewing 6 replies - 1 through 6 (of 6 total)
  • florianmarianna

    (@florianmarianna)

    if I uncheck the box “optimise HTML code”, it fixes the issue however, that’d be great if I could keep my code optimised without breaking the share buttons.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Could it be you’re also using W3TC (which was updated very recently) Marianna? I’ve had other people run into similar issues and the reason was the (apparently buggy) HTML optimizer in W3TC was loaded so AO could not load it’s own HTML optimizer.

    Anyway, as a workaround you could try wrapping that code in noptimize-tags;

    <!--noptimize--><script>your-code-here</script><!--/noptimize-->

    frank

    Hi,

    Thanks for your reply.

    I do have W3TC activated. However the minifying is not activated on W3TC.

    Also, whenever I activate/deactivate the HTML optimization on your plugin, it creates/fixes the issue so it seems that your HTML optimization is loaded as it has an impact on this issue.

    Regarding the noptimize, I don’t know how to do that inside the plugin php file (I’m not programmer unfortunately). For info, here is the php file that I guess I should edit:

    https://codeshare.io/2W4qOl

    Thanks again!

    Florian

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I do have W3TC activated. However the minifying is not activated on W3TC. Also, whenever I activate/deactivate the HTML optimization on your plugin, it creates/fixes the issue so it seems that your HTML optimization is loaded as it has an impact on this issue.

    I understand, but that’s not the problem as I saw it on that other site; it seems the W3TC update now loads the HTML (buggy) minifier even if that option is not active, meaning AO cannot load it’s own minifier and cannot but use W3TC’s.

    Now I do understand you need W3TC (a page cache), but maybe confirm the above by disabling W3TC if only for a couple of minutes?

    yeah you’re right, when I deactivate W3TC there is no more issue even if your HTML optimization is active.
    I just saw that they’re working on it: https://wordpress.org/support/topic/last-update-destroyed-html-minify-settings/

    I’ll wait for it then.

    Thanks again for your help!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    thank you for testing, confirming and providing the link to the W3TC support ticket @florianmarianna ! 🙂

    feel free to leave a review of the plugin and support here

    have a nice weekend!
    frank

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.