Support » Theme: Virtue » Issue with child theme and Virtue 2.3.0 update

  • dreadpiratebonney

    (@dreadpiratebonney)


    I tried updating from Virute 2.2.5 to 2.3.0 and I get the following error:

    Warning: require_once() [function.require-once]: Filename cannot be empty in /home/content/a/l/t/altstaffing/html/wp-content/themes/virtue-child/functions.php on line 37

    Line 37 in function.php file for the child theme is this:

    require_once locate_template('/lib/gallery.php');

    I poked around in the existing theme files and it looks like 2.2.5 has a /lib/gallery.php file in it and 2.3 does not so I assume this is what is causing the issue. My question is this: do I simply need to remove that line from the child theme to solve the issue or do I need to substitute a new file?

    Thanks for your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • dreadpiratebonney

    (@dreadpiratebonney)

    Update: I went ahead and tried just eliminating line 37 since it was the only one that didn’t have a match in the 2.3.0 functions.php file. It solved the error and everything looks fine so now I guess my question is this: have I caused any other trouble the I just haven’t noticed yet? 😉

    Theme Author Ben Ritner – Kadence WP

    (@britner)

    Hey,
    If your using a child theme you shouldn’t even have any of the parent theme functions in your child theme?

    Yes gallery.php was moved into the virtue toolkit plugin.

    Kadence Themes

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Issue with child theme and Virtue 2.3.0 update’ is closed to new replies.