Support » Plugin: Pods - Custom Content Types and Fields » Issue with archive page

  • Resolved cyberconstructionweb

    (@cyberconstructionweb)


    I used pods to create a CPT and a Taxonomy for the CPT. I created a custom archive page via WordPress’s page based archive creation. For example: archive-contractors.php.

    This has been working for about 2 years now. However, recently I’m getting a 404 error on this page. Know I know that pods is working because all my other CPT created in PODS are working. and if I create an archive page in PODS it works ok. The reason I had created this using a WP archive page was because of the formatting and indexing was easier to writing in PHP.

    What changed in PODS of WordPress recently that this is giving me a 404 error?

    Any help would be greatly appreciated.

    Thanks
    C

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @cyberconstructionweb

    Could you try to clear your Pods cache? (Pods > Settings > Clear cache)

    If this doesn’t help, please share the taxonomy name and settings with the issue. Also a page where we can see this behavior would be helpful!

    and if I create an archive page in PODS it works ok.

    What do you mean with “create an archive page in PODS”

    Cheers, Jory

    Thread Starter cyberconstructionweb

    (@cyberconstructionweb)

    I have cleared the PODS cache no help.

    To answer your question, I have created a standard WordPress archive page for the CPT that I created in PODS. So for example I have created a CTP called Contractors. Which has a Taxonomy for grouping by category. I then created a standard archive page called “archive-contractors.php” Which is giving me a 404 error currently.

    Now, I’m not 100% sure where the problem is because I’m not sure if it’s PODS the Theme or WordPress causing the issue. However, when I designed this website it was working fine up until recently.

    Thank you for you helping me on this if you’d be able to shed some light into what’s happening.

    -C

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @cyberconstructionweb

    Ah check. Have you enabled “Has archive” in the CPT options?
    This would be the main CPT archive, not a taxonomy.
    Taxonomies are a different type of archives 🙂

    Cheers, Jory

    Thread Starter cyberconstructionweb

    (@cyberconstructionweb)

    Thanks for your help. I’m not 100% sure if this was all of the problem. however, I have got it working again.

    Thank you for your help.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @cyberconstructionweb

    Glad to hear you’ve got it solved!

    Cheers, Jory

    Hi there

    Sorry if I use this ticket but I have a similar issue with my site. Until 2.8.3 version, the site I manage (I clear up I wasn’t who did it), all links worked. However, after we updated Pods one page no longer work.

    According what I see, each CPT page was created as archive template, but one of these archives give 404 error or redirect to home sometimes.

    Please take a look in this link and click on WORKS > TV Shows. This page is no longer work 🙁

    I also tried with this option ‘Pods > Settings > Clear cache’ but I didn’t work.

    I’d appreaciate if you can guide me how to fix it.
    Let me know if you need additional info.
    Best regards`

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @gfdesign

    It seems that link redirects to your homepage. This might be because something changed in your CPT configuration. Please make sure the archive options are enabled for this post type.
    And if it’s an extended post type then you need to find the location where the post type is registered (theme or plugin?) and change it there, or remove that code and fully create the CPT through Pods.

    Cheers, Jory

    Hi Jory
    Thanks for replying me.

    According what I understood, these CPTs were created using Pods.
    Please, take a look if I am wrong.

    If it is so, where should I enable the archive options on Pods setting?

    Looking forward to your comments.
    Best regards`

    Jory, I looked at CPTs that we can’t access in the front end but they have enable the archive option.

    Any other idea?
    Until 2.8.3 version, these links worked fine.

    Thanks for your time.
    Best regards

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @gfdesign

    Looks good from here so there must be a different issue.
    Are you sure you can reproduce this behavior with just Pods active on a default theme?
    https://docs.pods.io/faqs/plugin-theme-conflicts/

    If that is the case, please create a full bug report, providing all packages for us so we can try to reproduce this behavior:
    https://github.com/pods-framework/pods/issues/new/choose

    Please also reference this issue within the bugreport!

    Cheers, Jory

    Hi Jory

    Look like the problem is with our custom theme.
    In a default theme I see no issues at first glance.

    I’ve been able to find to original author of this custom theme (he did it several years ago), so I hope he can help us to fix these bugs.

    Thanks for your replies and for your time.
    Best regards

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @gfdesign

    No problem! The original author can jump in here if he needs assistance.

    Cheers, Jory

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Issue with archive page’ is closed to new replies.