Support » Plugin: WooCommerce » Issue with Affiliate Links

  • Resolved dphillipsfern90

    (@dphillipsfern90)


    Good morning, I urgently need some help please. This morning I noticed that for some reason my ‘BUY NOW’ buttons are suddenly broken on my product pages.

    If I click ‘BUY NOW’ on the category page directly, it transfers the user over to buy the product correctly, however if I click into the product page and then try to press BUY NOW, the link is slightly different and is therefore broken.

    e.g on this page here;
    https://www.giftageek.co.uk/

    If I click buy now on the first new product – ‘World’s Okayest Dad Beer Glass’, it correctly points to the affiliate URL http://tidd.ly/e2468663 which works correctly.

    However, if you click into the product page here: https://www.giftageek.co.uk/product/worlds-okayest-dad-beer-glass-for-the-average-father/

    and press buy, the broken link appears as https://tidd.ly/e2468663? – so its now HTTPS and has a ? at the end of the url..

    Obviously in WooCommerce product page it is set to the first link.

    Any clue what is going on? It was working fine until maybe last week?

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Amanda

    (@amandasjackson)

    Hi there,

    You will first want to try Go to settings > permalinks and save. Then clear caches.

    If that doesn’t work, it could be a plugin or theme conflict.

    The best way to determine if the issue is being caused by a theme and/or plugin is to temporarily switch your theme to Storefront and disable all plugins except for WooCommerce. If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you while you’re logged in to that session without affecting normal visitors to your site. Note that Health Check may not count Storefront as a default theme, so you can also use Twenty Seventeen as well.

    If that resolves the issue, then one-by-one you can switch back your theme and re-enable your plugins, testing in between, until you find the one causing the conflict.

    Plugin Support Kenin

    (@kbassart)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Issue with Affiliate Links’ is closed to new replies.