Support » Plugin: Room 34 presents On This Day » issue with 2.0.1

  • Hey. I updated On This Day to 2.0.1 on my test site recently. After updating, WP-CLI stopped working, and issued the following errors:

    Warning: key() expects parameter 1 to be array, null given in /…/MyCMS2/wp-content/plugins/room-34-presents-on-this-day/archive.php on line 71
    Fatal error: Unsupported operand types in /…/MyCMS2/wp-content/plugins/room-34-presents-on-this-day/archive.php on line 63

    The site itself was functional, but WP-CLI stopped working. I disabled On This Day, and WP-CLI started working again.

    My test site is running WP 4.7.2, WP-CLI 1.0.0 (provided by my host), and PHP 5.6.30.

    I’m going to leave my production site on an older version of On This Day for now. Just thought I should tell you about the issue. (And it’s still one of my favorite plugins!)

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author room34

    (@room34)

    Thanks for the tip! I’ll check this out and roll out a fix asap.

    Plugin Author room34

    (@room34)

    Hi again @andyhuey,

    I took a look at the issue, and I’ve just rolled out version 2.0.2, which I hope resolves it. I am not actually using WP-CLI and don’t have time right now to install it and thoroughly test, but the changes I made are fairly innocuous, and I confirmed that they have no effect on the standard web browser implementation.

    It’s always a bit tough to know if you’re on the right track debugging an issue that you can’t directly test, so this might not resolve the issue. Please update to 2.0.2 when you have a chance and let me know if it works for you with WP-CLI. Thanks!

    Hey, thanks for responding! I did update to 2.0.2 today, and it works great.

    Plugin Author room34

    (@room34)

    Thanks! I’m glad to hear it’s working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘issue with 2.0.1’ is closed to new replies.