Support » Plugin: Accept Stripe Payments » Issue when closing the popup

  • I am facing the issue when I have to close twice the popup to go back to my page.

    This happens only on the first load of the page.

    Strange.

    Please take a look at this short video.

    Thanks

Viewing 9 replies - 16 through 24 (of 24 total)
  • Thread Starter hamarkhis

    (@hamarkhis)

    OK, flushing browser cache AND cookies solved the issue.

    It’s problematic because a customer is going to have the same experience on closing the popup.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    It might be caused by a conflict with some other plugin or theme.

    On your staging site, can you disable all plugins but Stripe Payments and also switch to default WP theme (Twenty Twenty) and see if the issue persists? If it’s not, try to enable your theme and try again. If still no issue, try to enable plugins one by one and check after each plugin. When issue happens after activating some plugin, this means it causes the conflict.

    Let me know the results.

    Thread Starter hamarkhis

    (@hamarkhis)

    OK, the results are :

    1) all plugins disabled, cache disabled, theme disabled : the issue still there after one page refresh.

    2) I decided to switch from Safari browser to Chrome. And there isn’t any issue. Reactivating everything, no issue with Chrome.

    Thread Starter hamarkhis

    (@hamarkhis)

    Other tests have been done and the issue has been reproduced on iPad, other MacBooks in Safari.

    Steps to reproduce the issue.

    1) Launch Safari
    2) Go to https://freshsite.mystagingwebsite.com/sample/ (this site contains nothing except the plugin)
    3) click the blue button
    4) refresh the page
    5) clic again the blue button, the popup appears again.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    I was able to reproduce this on my test server by using Safari on Mac. Looks like this issue is only affecting Safari browser. When I try Chrome or Firefox on Mac, there is no issue.

    I have created a ticket in our bug tracker to get this fixed. Since a fix would require some thorough testing, I cannot provide any ETA when this is addressed. But this issue does not seem critical as not many customers are opening payment popup, closing it, then refreshing page and opening payment popup again to just close it 😉

    Thank you so much for helping to nail this one.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    This should be fixed in current testing version of the plugin. Go to Stripe Payments -> Settings, look at the right side column.

    Install it on your staging site and try it on your Apple devices.

    Thread Starter hamarkhis

    (@hamarkhis)

    Ok thanks.

    I’m gonna do it as soon as I have the link to do that.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    You can find the link to testing version here:

    Go to Stripe Payments -> Settings, look at the right side column.

    Thread Starter hamarkhis

    (@hamarkhis)

    Hey, thanks.

    Plugin updated.

    Results are a little bit strange, after refresh and one click on close : the popup is closing, then poping again, and closing.

    I did not expect that, but finally this popup is closed 🙂

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Issue when closing the popup’ is closed to new replies.