Support » Plugin: Contact Form 7 - Conditional Fields » Issue using conditional fields in mail 2

  • Resolved divago

    (@divago)


    Hello,
    what we are trying to do is this:

    [group 1][email my-email][/group 1]
    [group 2][email your-email][/group 2]

    After that we need to send an automatic email to the selected one.

    We filled the “mail to” field of the Mail (2) section with something like this:

    [1][my-email][/1][2][your-email][/2]

    we are getting nothing back as you probably know. Can you please help?

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jules Colle

    (@jules-colle)

    Try to fix your naming. A valid name should start with a letter (a-z, A-Z)

    So name your groups in your form like this:

    [group g1]...[/group]

    Also, take note that it should be written as above, and NOT like this:

    [group g1]...[/group g1] <-- WRONG

    After you renamed your groups and updated your conditions accordingly, this should work in the Mail To section:

    [g1][my-email][/g1][g2][your-email][/g2]

    Good luck!

    Hello,
    i am sorry, i made an error writing this post..
    this is the code we used:

    [group switch-pers clear_on_hide]
    [email* pers-email placeholder "Personal Email"]
    [/group]
    [group switch-comp clear_on_hide]
    [email* comp-email placeholder "Company Email"]
    [/group]

    and in the mail section:

    [switch-pers][pers-email][/switch-pers][switch-comp][comp-email][/switch-comp]

    So, assuming that we made no mistakes, and conditions work good, according to you why emails are not being sent?

    Thank you.

    Plugin Author Jules Colle

    (@jules-colle)

    This looks good. I have have no idea why it wouldn’t work. Can you send emails with conditional fields plugin disabled?

    • This reply was modified 2 months, 3 weeks ago by Jules Colle.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.