• Resolved Tano

    (@tanohex)


    Please note that I found an issue when trying to translate the actual learn page using the TranslatePress plugin.
    When you try to translate, you get the following:

    Every other page can be translated without any issues (account, course etc.), the problem appears only on the learn page.

    TranslatePress is an extremely popular plugin, that lets you easily translate every string on a page.

    Now, it would be great if you could also achieve WPML compatibility, as this is another amazing translation plugin.

    Making these 2 compatible with Masteriyo would be amazing.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Aashil

    (@lihsaa)

    Hello @tanohex

    We have tested this from our end and it seems like translation works fine on learn page too. Here is our screenshot: https://i.imgur.com/q665f6s.png

    Please can you verify if learn page is set on global setting > Advanced > Pages setup? If it’s not working please try to update the permalink once. If the still issue persists then try reactivating the plugin. This might get resolved after this.

    Thank you.

    Plugin Support Aashil

    (@lihsaa)

    Also, Regarding the plugin compatibility with other translation plugins, we will try to make our plugin as much as compatible with others.

    Thanks 😊

    Thread Starter Tano

    (@tanohex)

    Please can you verify if learn page is set on global setting > Advanced > Pages setup? If it’s not working please try to update the permalink once. If the still issue persists then try reactivating the plugin. This might get resolved after this.

    Nope, same issue. I deactivated/reactivated all plugins.
    Here are my settings:

    
    <a href="https://i.ibb.co/d7Z34jp/learn.png"><img src="https://i.ibb.co/d7Z34jp/learn.png" /></a>

    Testing on localhost (WP 6.0, PHP 8.0.15, Masteriyo 1.5.3).

    Also, I noticed that the Learn page conflicts with the display of some elements on the WP admin bar.
    For example, the Translate Page plugin icon is removed, and the Query Monitor plugin shows a weird QM label.
    This happens only on the Learn page.

    
    <a href="https://i.ibb.co/44HTTTy/conflict.png"><img src="https://i.ibb.co/44HTTTy/conflict.png" /></a>
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.