Support » Plugin: WP Hide & Security Enhancer » Issue slow site and not properly working

  • Hello,

    When I rename wp-includes and the other folders, the site is very slow to load and it doesn’t display correctly.
    Looking at the inspector, it appears that the assets are not found but the paths’ files is well renamed :

    original : /wp-includes/plugins/…
    new : /my-includes/plugins/…

    in the inspector, I can see that files are requested from the new path but they are not found.
    What did I do wrong/miss ?
    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author tdgu

    (@tdgu)

    Hello,
    For some reason the rewrite does does not work for your side. Can you check with your server if use .htaccess for rewrite? it might rely on Nginx config.

    Thanks

    Hello,

    I am (almost) sure that rewrite rules work because I have plenty of URLs that use it and it works.
    Yes it uses an .htaccess file with this in it (I think that it added by WPH) :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .*.html?$ index.php [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>

    By the way, I realized 4 hours ago that this is present a lot of time in the .htaccess (maybe 12 times), I think it adds this cond each time (at least) I reactivate the plugin.
    Another thing, I tried modifying the rights on the .htaccess 604 -> 644. And I also realized that each time I refresh the folder, the rights come back to 604 and the date come back to an old date! Even if I replace the file after downloading it.

    Plugin Author tdgu

    (@tdgu)

    Hello,
    Nope, the above rewrite it appear to be a WordPress ( however not a standard one?! ). Possible your host filter that somehow, as the default is as follow:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Try replacing your code with the above and see if duplicate again when change any option in WP Hide interface.

    After all, might be a problem caused by the server environment.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Issue slow site and not properly working’ is closed to new replies.