Support » Plugin: LiteSpeed Cache » Issue plugin PDF Embedder

  • Resolved alaid

    (@alaid)


    Hi

    I installed the PDF Embedder plugin, it does not work with Minify JS and Combine JS in LiteSpeed ​​Cache, error is caused:

    Setting up fake worker failed: “Cannot load script at: https://domain.com/wp-content/litespeed/cssjs/7e923.worker.js”

    To try to solve this I disable Minify JS and Combine JS, then from GTmetrix / Waterfall Chart / JS I have 41 JS files, I removed the PDF Embedder plugin, purged the entire cache and again ran the test and still have 41 JS files running.

    My intention was to find out which JS file is using the PDF Embedder plugin to exclude it, but since I have the same 41 JS files after repeating the test again, I don’t know which JS file is using the PDF Embedder plugin.

    If the PDF Embedder plugin is deleted, shouldn’t the GTmetrix test have fewer JS files?

    How can i fix this?

    Right now the PDF Embedde plugin, Minify JS and Combine JS in LiteSpeed ​​Caché are active producing the error.

    Report Number: AETBVJYW

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please check this wiki

    You will need to repeatedly test it until figure out which one is actually causing it

    you can remove like half of the JS’ in the list each time , this will speed up things.

    best regrads,

    Thread Starter alaid

    (@alaid)

    Hi

    I added all the JS one by one in the JS exclusion list, but it doesn’t work, it keeps showing the error.

    When I test with GTmetrix the 40 JS files excluded appear.

    Please check to see what happens, here is the Report Number: TWGNPXLO

    Why if I excluded all JS files it doesn’t work?
    When I disable Minify CSS and Combine CSS it works, although the issue occurs with Minified CSS

    Thanks

    Best Regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Why if I excluded all JS files it doesn’t work?

    make sure you have purge all after you make any change.

    now , please try put

    wp-content 
    wp-include

    into excluding list, purge all , does it work ?

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi

    Now if it works, but what happens, why adding these files if it works? What should I do?

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Now , remove one of them , see which one works

    Best regards,

    Thread Starter alaid

    (@alaid)

    HI

    When I add / wp-content it works, but without this it produces the error.

    I added just / wp-content without the rest of the JS and it works.

    What am I supposed to do now?

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    OK , now please try use following

    /wp-content/plugins
    /wp-content/themes

    if with these 2 it still works , repeat previous step , remove one of them , see if it’s “plugins” or “themes” caused issue.

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi

    /wp-content/plugins caused issue.

    Now?

    Best regards

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Now use FTP or control panel file manager

    you should see some sub-directory inside of /wp-content/plugins , like

    /wp-content/plugins/litspeed-cache
    /wp-content/plugins/plugin-name1
    /wp-content/plugins/plugin-name2 
    ...
    ...
    ...

    add them into the excluding list , then repeat the previous steps to narrow it down

    one quick check is add that PDF plugin into it first and see how it goes.

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi

    With the PDF plugin it works.

    Should I leave it like that then?

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    You can leave with that

    if it contains a lot of JS , then you can further narrow it down

    if it only contains one or few JS , then it may not worth the trouble.

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi

    Resolved

    Thanks

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    good to know 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Issue plugin PDF Embedder’ is closed to new replies.