Support » Plugin: Async JavaScript » Issue: Padding content and header problem

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    maybe try excluding the JS of your theme (or maybe a plugin) from asyncing abstractstudio. lots of things to configure on the settings page πŸ™‚

    abstractastudio

    (@abstractastudio)

    Hi.

    First of all I must say that the plugin found it very useful.

    The majority of us who come to this one, we do it because in some way the obsession we have with the Google PageSpeeed qualifications makes us arrive here.

    However; As usual, each plugin goes off until it identifies which one is causing the anomaly.

    In this case I turned off:

    – Autopmize

    – a3 Lazy Load and

    -Async JavaScript

    The problem I was presented with is that when editing the customize of “Layers child” the blog section looks perfect in relation to the padding between the header and the content (approximately 50px) but when publishing (when these plugins come into action) padding is overridden by the header causing that space to be lost.

    Certainly I will continue doing tests and it would be helpful if there was a tutorial that explained in more detail the configuration of Async JavaScript.

    I value the effort of each developer who proposes the challenge of improving the wordpress functionalities.

    When I get more technical precisions (Chrome inspector) I will publish them in this post.

    Β THX

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, if you can share your sites URL I’ll be happy to have a quick look myself πŸ™‚

    abstractastudio

    (@abstractastudio)

    Hi!

    I just published a page to study this issue.

    In it I have a capture without async-javascript other with async-javascript and a third that is taking me by surprise that apparently does not have to do directly with your plugin.

    I’m using WP version 5.02

    Anyway; I do not know what to think.

    https://www.studioh.com.ve/Home/async-javascript/

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    try excluding wp-content/themes/layerswp/assets/js/layers.framework.js both from AO and AsyncJS

    also; rocketloader can make things more complex to troubleshoot; disable it until you’ve fixed the padding problem maybe? πŸ™‚

    Hi:

    I did the exclusion in AO (css & js) and everything normal but when activating AS the problem returned even with the exclusion.

    You can review the capture in the same link.

    TY

    P.S.

    I do not use rocket loader.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    re. problem; will need to see this happening I’m afraid, do you have a non-production site on which you can leave things (somewhat) broken?

    re. rocket-loader: your HTML source disagrees (taken from the bottom);
    <script type="88df307b3197589eb6aa6899-text/javascript" defer src="https://www.studioh.com.ve/Home/wp-content/cache/autoptimize/js/autoptimize_677794ce2abfc1c93337e754289d35fa.js"></script><script src="https://ajax.cloudflare.com/cdn-cgi/scripts/2448a7bd/cloudflare-static/rocket-loader.min.js" data-cf-nonce="88df307b3197589eb6aa6899-" defer=""></script></body></html>

    For the next week I will create a clone of non-production (I have not needed so far since I very rarely update this website) but nevertheless; I am interested in mastering all the updates when I attend clients.

    Thank you very much for your kind attention.

    About “rocket-loader” This comes from cloudflare since I use it as a reverse proxy. I will check it.

    Merry Christmas!

    JC

    People usually submit issues into the support thread and don’t give a 1 Star review for such things. Just saying!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this review.