• Resolved phaser32

    (@phaser32)


    Good morning, I would like to report a very serious problem that we are facing. After the 5.9.3 release we encountered anomalous behavior during sending on several sites (created with different themes and plugins). The behaviors cannot be traced back to specific errors and I report below two different behaviors for example_

    • the form is not sent and the hourglass remains and nothing happens (no errors in the console)
    • the form is not sent and two errors appear in text fields and in checkbox fields with the message “invalid value” (but the message is misleading as there is no control in the text field and the checkbox has no option that can discriminate the error factor (there are only two exclusive options available).
      We fixed the problem by reinstalling version 5.8.7

    We are awaiting your kind response.
    Ale

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Where can we see the website in question?

    Thread Starter phaser32

    (@phaser32)

    First of all thanks for reply Mr Takayuki!
    As mentioned before the websites are more then one but you can take a look to this one: https://docsign.phaserdesign.net/modello-di-lettera-di-incarico-professionale-scarica-e-compila-in-pochi-minuti/
    In this case You won’t see the error because as I reported in the previous post, we rolled back to 5.8.7 and now everything works fine.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    Thread Starter phaser32

    (@phaser32)

    Hi,

    here is the list of installed plugins:

    Classic Widgets
    Contact Form 7
    Contact Form 7 - Dynamic Text Extension
    Contact Form 7 Signature Addon
    Disable Gutenberg
    Docket Cache
    EWWW Image Optimizer
    Favicon by RealFaviconGenerator
    Heartbeat Control by WP Rocket
    Jquery Validation For Contact Form 7 (Lite)
    Loginstyle Admin Login Customizer & Styler Developer Version
    plugin load filter
    Post Types Order
    Responsive Pricing Table
    Send PDF for Contact Form 7
    SVG Support
    The7 Elements
    Ultimate Addons for WPBakery Page Builder
    Under Construction
    WeePie Cookie Allow
    Wordfence Security
    WP Mail SMTP
    WP-Optimize - Clean, Compress, Cache
    WPBakery Page Builder
    WPS Hide Login
    Yoast Duplicate Post
    Yoast SEO


    But You should consider that we have noticed the same behaviour in other website with different config and plugins installed.
    Thanks for attention

    Warm regards

    Ale

    Thread Starter phaser32

    (@phaser32)

    Good morning Mr Takayuki,
    I identified the problem and I explain it below because maybe it could be useful to someone.
    In reality the problem is linked to a custom function that I had created to change the format of emails sent in PDF format with the “Send PDF for Contact Form 7” plugin. The changes I made were in the functions.php file of the theme used.
    The code I entered was the following:


    /* START CHANGE DATA FORMAT CF7 */ add_filter( ‘wpcf7_posted_data’, ‘custom_format_all_dates’ ); function custom_format_all_dates( $posted_data ) { foreach ( $posted_data as $key => $value ) { if ( preg_match( ‘/^\d{4}-\d{2}-\d{2}$/’, $value ) ) { $date = date_create_from_format( ‘Y-m-d’, $value ); $formatted_date = date_format( $date, ‘d/m/Y’ ); $posted_data[ $key ] = $formatted_date; } } return $posted_data; } / END CHANGE DATA FORMAT CF7 */


    Until contact form 7 version 5.8.7 everything worked correctly but after the 5.9 update it started to stop sending emails.
    Most likely because the way in which the data is wrapped before being sent has changed.
    I removed the change and everything works correctly (although the “Send PDF for Contact Form 7” plugin continues to send the date in the wrong format (but at this point it no longer concerns it).
    I apologize for not delving deeper into the topic sooner and for wasting your time.

    Have You a great day
    Ale

    • This reply was modified 2 months, 2 weeks ago by phaser32.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.