Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Issue on page Load

  • Resolved loano1

    (@loano1)


    Hi,

    in the first milliseconds on page load the cookie banner text appears in the top left corner (desktop), then it jumps down to the bottom right corner. Is there any way to avoid this behavior? How to load it after it has found its final position?

    Thanks!

    Update: I just saw the same behavior on your own website here (Desktop): https://complianz.io/placeholders-for-iframes/

    I’m using the latest version of Chrome and my internet connection loads with about 800 MB/sec. It looks like the websites are loading blazing fast and the cookie banner cannot compete with this high speed.

    • This topic was modified 3 months, 1 week ago by loano1. Reason: New findings

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @loano1,

    Do you have a CDN or any caching plugins active that might have an influence on this?

    Let me know if you have any updates.
    Kind regards,
    Jarno

    • This reply was modified 3 months, 1 week ago by jarnovos.
    Thread Starter loano1

    (@loano1)

    Hi @jarnovos

    Thanks for your reply. Yes I do use a CDN and caching as well and both is required in todays world where pagespeed matters most. I think your plugin somehow has a general issue on fast load. In the meantime I could see the issu on multiple sites using your plugin including your own homepage. Here a video of the issue:

    Since I already gave consent to the cookies I see it as box. Before the banner text was appearing on the same positon. It is not a huge issue, I just don’t like it when the page jumps like that when it loads. It would be great if this could be fixed with one of the next updates.

    Thanks!

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    We’re currently working on a complete makeover of the banner structure, which will also resolve this issue.

    There will be some minor updates first, you can expect this in the 6.0 update.

    Thread Starter loano1

    (@loano1)

    Hi @rogierlankhorst

    Thank you for your feedback. I am glad to hear that the problem will be solved. I am looking forward to the update.

    @rogierlankhorst, I’m experiencing a similar issue.
    It loads the ‘toestemmingen beheren knop’ (permissions button I guess?) above the page, then it disappears.

    I already selected the ‘hide permissions’ option but it still loads the button – after which it disappears. It which makes the page jump as said before. I noticed this issue isn’t present on your site, so is there a temp. fix for this?

    As I read there will be a few small updates before 6.0 is coming out, so otherwise the solution will take a while?

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @marketingspectrum this might happen if you have a “delay/defer javascript” functionality active.

    If that is the case, you can resolve it for now by excluding complianz.min.js from the defer.

    We’re planning to have a 6.0 beta ready in september. If you’re interested in beta testing you can send us a message at support(at)complianz.io.

    After 6.0 this shouldn’t be an issue anymore.

    @rogierlankhorst thanks!
    Need to dive a bit deeper into this, adding the complianz.min.js to the excluded delayed and defered boxes didn’t do the trick yet.
    Will find out when I have more time, thanks for you superb support as always!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.