Support » Plugin: MaxiCharts » Issue “No data available for fields” on multiple choice field

  • Resolved pierrethenot

    (@pierrethenot)


    Hi, I’m having issues with the plugin when trying to fetch and display multiple choice field data with a chart. It doesn’t matter what chart type I use, it always tells me “No data available for fields”. All my multiple choice fields have this issue.

    Can you help me figure it out?

    Cheers,

    Pierre

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author maxicharts

    (@maxicharts)

    Hi @pierrethenot,

    It seems you link is only accessible after authentification… any credentials?

    Have you double check that you really have answers for those fields?

    Can you please display the page and send me le log file located under logs/

    Thanks

    Hi,

    Sorry about the credentials. Can I send them to you by email? as it grants you access to the form and it is being used right now by my client. Here is my email : pierre@helium.nc

    I have answers for those fields. I got 735 entries.
    You can find the log file here : http://cactusnc.com/logs/maxicharts-2018-06-11.log
    It says “Unknown field type : multiselect”.

    Cheers,

    Pierre

    Plugin Author maxicharts

    (@maxicharts)

    Please use the contact form here : https://maxicharts.com/contact/
    Thanks

    Thanks, I just sent you the credentials through the contact form.

    Plugin Author maxicharts

    (@maxicharts)

    Ok, i haven’t read correctly your feedback, but yes, actually the multiselect field is not processed at the moment.
    That’s why. The log was saying the truth.
    It is possible to add the process for it inside maxicharts.
    We are going to evaluate how to get this done.
    Thanks for your understanding.

    Plugin Author maxicharts

    (@maxicharts)

    Hi,
    A new version have been released, can you please delete “maxicharts gravity forms add on” completely, re-install, and test if multiselect works.
    Waiting for your feedback to make an official release.
    Thanks

    Hi, Thanks for the quick reply. I tried the new version, but there is an issue with the data collected for each “choice”. It says there is no data. here is the log file : http://cactusnc.com/logs/maxicharts-2018-06-12.log
    The field values are right though.
    I also tried to submit a new entry in case it only collect new ones, but it’s still at 0 with the message : “No answers yet to field number 10 : Type de bien”.

    Cheers,

    Pierre

    Plugin Author termel

    (@munger41)

    Thanks,

    Can you please go to maxicharts/mcharts_utils.php line 9 and replace the line:

    define("MAXICHARTS_DEBUG_LEVEL",'info');

    with

    define("MAXICHARTS_DEBUG_LEVEL",'debug');

    Then please reload the page and send me the log file again.
    Thanks!

    Hi,

    Here is the new log file : http://cactusnc.com/logs/maxicharts-2018-06-13.log

    regards,

    Pierre

    Plugin Author maxicharts

    (@maxicharts)

    What do you see on the page ?
    It seems some graph should be displayed correctly, no?
    This one for example:

    [label] => Bien recherché
    [graphType] => horizontalBar
    [type] => checkbox
    [scores] => Array
    (
    [Vente] => 28
    [Location] => 172
    )

    No ? Can you provide a screenshot or an access to the page please ?

    On the page I see all my graphs working except for the multiselect field id number 10. It displays a message : “No answers yet to field number 10 : Type de bien ”
    That corresponds to field id 10 in the log.

    2018-06-13 20:53:14,107 GF WARN /var/www/vhosts/cactusnc.com/httpdocs/ckimmo/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php:683 No answers for field 10
    2018-06-13 20:53:14,107 GF WARN /var/www/vhosts/cactusnc.com/httpdocs/ckimmo/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php:684 Array
    (
    [orderedAnswers] => Array
    (
    [F1] => 0
    [F2] => 0
    [F3] => 0
    [F4] => 0
    [F5] => 0
    [F6] => 0
    [Villa] => 0
    [Dock] => 0
    [Bureau] => 0
    [Commerce] => 0
    [Terrain] => 0
    [Parking] => 0
    [Autre] => 0
    )

    [valuesAndLabels] => Array
    (
    [F1] => F1
    [F2] => F2
    [F3] => F3
    [F4] => F4
    [F5] => F5
    [F6] => F6
    [Villa] => Villa
    [Dock] => Dock
    [Bureau] => Bureau
    [Commerce] => Commerce
    [Terrain] => Terrain
    [Parking] => Parking
    [Autre] => Autre
    )

    )

    I sent you the credentials to see the page in your contact form on the maxichart website.
    Here is a screenshot : https://we.tl/FSylsfPwUq

    Plugin Author maxicharts

    (@maxicharts)

    Ok, sorry but, can’t see anything, can you please change again log level to “trace” instead of “debug” and try to display in a shotcode ONLY results for field 10, adding in the shortcode something like:

    include="10"

    Then please send the log file again
    Cheers

    Plugin Author maxicharts

    (@maxicharts)

    don’t forget to set debug level back to debug or info after that because trace level is extremely verbose and will slow your site down.
    Thanks

    Hi,

    I made a copy of the website without the force login. here is the new link so you can see the page : http://cactusnc.com/ckimmotest/graphiques

    I also changed the log profile to “Trace” and only kept the ‘include=”10″‘ shortcode. Here is the code I use on my template.

    <?php

    /* Template Name: chart */

    get_header(); ?>

    <div class=”container chart”>
    <div class=”row”>
    <div class=”col-lg-12 col-sm-12″>
    <div class=”bloc”>
    <span>Types de biens</span>
    <?php echo do_shortcode(‘[gfchartsreports include=”10″]’); ?>
    </div>
    </div>
    </div>
    </div>

    <?php get_footer(); ?>

    It still displays the same message : “No answers yet to field number 10 : Type de bien”.

    Here is the log : http://cactusnc.com/logs/maxicharts-2018-06-14-2.log

    Regards,

    Plugin Author maxicharts

    (@maxicharts)

    Thank you very much for your help.
    I think i found the bug.
    Can you please delete completely the plugin, and re-dowload, install and test please ?
    Thanks

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Issue “No data available for fields” on multiple choice field’ is closed to new replies.