Support » Plugin: Order Your Posts Manually » Issue in sitemap page – urgent

  • Resolved shyammacrosoft

    (@shyammacrosoft)


    Hello Support,

    We are getting some error in sitemap page. Please see below:
    “This page contains the following errors:error on line 6 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.”
    Once we disable the plugin, this error is gone.

    Also when the plugin is re-enabled after deactivating we are getting this error:
    The plugin generated 20 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    We are using latest wp version and plugin is also uptodate.

    This seems to be related to some space issues. Could you please check and get back to us asap? Waiting for your response.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author cageehv

    (@cageehv)

    Hey shyammacrosoft,

    1) sitemap:
    Which plugin are you using for the sitemap?
    Try to disable the sitemap plugin and check if my plugin works.

    2) deactivating / re-enabling my plugin:
    I cannot reproduce that error. For me it works flawless.

    Rolf

    Thread Starter shyammacrosoft

    (@shyammacrosoft)

    Hello Rolf,

    Sorry for the late reply.
    Yoast seo plugin provides sitemap xml. We can access those by taking site.com/sitemap.xml.
    But when accessing those in our site – we are getting this error:
    “This page contains the following errors:
    error on line 6 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.”

    On further troubleshooting we identified – when “order your posts manually” is activated – this issue is occuring. Otherwise, there is no issue and sitemap is loading.

    Could you please check this? We are having the latest version available for “order your posts manually”. Please advise.

    Plugin Author cageehv

    (@cageehv)

    Hey shyammacrosoft,

    I also use Yoast with sitemap enabled. No problems for me.

    The only thing I can think of is that some other plugin messes things up.

    Temporarily disable all plugins (except for mine).
    Then enable them, one by one and see where the problem starts.

    Rolf

    Thread Starter shyammacrosoft

    (@shyammacrosoft)

    Hello Support,

    We have tried that, the issue happens when we enable this plugin. After that, sitemap is not working like i mentioned.
    I can confirm that the plugin and wp version is the latest one.
    What to do? Please advise.

    Thanks again.

    Plugin Author cageehv

    (@cageehv)

    Hey shyammacrosoft,

    I tried again but was not able to reproduce the issue…
    With Yoast sitemaps switched on, my plugin still runs fine.

    If you switch off Yoast sitemaps on your site, does that solve the issue?

    One other thing I can think of is: maybe some of the Yoast sitemap .xml files are corrupted. You could manually delete them and let Yoast generate new ones.

    Please let me know,

    Rolf

    Thread Starter shyammacrosoft

    (@shyammacrosoft)

    Hello Support,

    we have checked, but issue is still there. We have tried disabling all plugins and enabled this only – the issue exists. When we disable this plugin, there is no such issue.
    Could you please check? Waiting for your reply.

    Plugin Author cageehv

    (@cageehv)

    Hey shyammacrosoft,

    I’m out of suggestions…

    I cannot reproduce the issue myself and all the ideas I gave you didn’t work.

    I’m sorry!

    Rolf

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Issue in sitemap page – urgent’ is closed to new replies.