[resolved] Issue in RSS Feed with <guid> tags (3 posts)

  1. TheWoopWoop
    Posted 6 years ago #

    I am having an issue with my RSS feed. The content formatting within the <guid> enclosures seems to have changed. Before I would get something like this in my RSS feed:
    <guid isPermaLink="false">http://wordpress.com/?p=230</guid>

    Now I get these guid entries instead:
    <guid isPermaLink="false">1349370363</guid>

    Old posts still work the proper way in the RSS feed, but new entries have guid tags that are filled with numbers. These numbers seems to sporadically change as well and then feed readers download the articles all over again. In the case of my podcast posts it is causing iTunes to download the MP3 file over and over again.

    Why did this shift happen, and is there any way that I can revert it to the old behavior?

  2. TheWoopWoop
    Posted 6 years ago #

    I should add that this first started happening in late September. I have not added any new plugins or done any updates at all except moving to 2.6.3 though the problem seems to precede that release.

  3. TheWoopWoop
    Posted 6 years ago #

    This problem is being caused entirely by the PodPress plugin. I am not sure why it started doing this, but given the fact that the project has been abandoned by its developer and has serious issues with WordPress 2.6 it was already looking really unattractive. This is just the final nail in the coffin.

    This weekend I will be migrating all of my posts to the new Podcaster plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic